Evolution feedback - cut email below a delimiter

I’ve been using Evolution for a couple of years and I love it, it’s a great application.
Recently though Evolution introduced a change where it cuts an email when you reply, everything below a signature delimiter goes out of the window.
Initially I started writing a reply to an issue here, but issues are not a place for feedback or discussion, right?
So I decided to come here with my opinion and a question:

Sadly, this change breaks my workflow.
Everyone in my company signs their reply, not their email.
This means there are lots of signatures in threads, and many delimiters.
I don’t think I can change how everyone else composes their emails, so it seems I am forced to change my email client.
No other email client I know of cuts everything below a delimiter and to put it bluntly I don’t see how this change is improving anyone’s workflow, it just looks alienating to users who sign their replies.
I tried to find a gsetting for it but it seems there is none?

Hi there. I think there is really a bug in how the signature is interpreted. Do the following experiment — reply to your own message with those settings:

[ ] Start typing at the bottom
[x] Keep signature above the original message

The signature will appear within the quote below instead of above it. The quote will be no longer what has been written in the original message, which is definitely not expected to happen. At least that’s what I observe in the most recent version from Ubuntu (3.38.1-1). I haven’t seen the cutting behavior you describe though; replying to messages of others with the signature above the quote works perfectly fine for me. In any case, something’s fishy about signatures.

Yep, these are exactly my settings.
Here is me replying to my own message for the third time.
You can see that the very first email got cut along with a signature for the second email.
The same happens when I reply to my colleagues - I get only the body of a message I reply to as a quote (with no signature), and above it my own signature, nothing else.

evolution 3.38.3-1
Debian Testing

image

For comparison, here’s what I see when replying for the second time on 3.38.1-1. The first two messages had no signature. The signature from the present message is injected into the bottom quote.

image

Thanks to the person who originally reported a bug here is the solution:
gsettings set org.gnome.evolution.mail composer-reply-keep-signature true

That’s a nice tip, but it didn’t solve my problem of signatures being inserted into quotes. As it appears to be a slightly different problem than yours, I started a new issue here.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.