Evolution EWS calendar sync issue

Dear all,
first, I want to thank everybody who contributes to Evolution, it is the software I use most and it is very well done. Unfortunately, after years of stable operation, I got now a problem:
I am connected to an exchange server via EWS. Suddenly, the downsync (appointments written by my secretary sharing my calender via OWS) did not sync anymore. Upsyncs (appointments written by me in Evolution) work, they show up e.g. when she or I start the OWS calendar.
Even worse, this works and does not work intermittently, I did not find any systematics. Reinstalling., removing cache et. did not help.

When I start Evolution from the command line, there are no particular messages when I try to sync (refresh) the EWS calendar. When I try to import a local .ics file into the EWS calendar, I get the following warning.
(evolution:5837): GLib-GIO-WARNING **: 09:11:57.040: Your application did not unregister from D-Bus before destruction. Consider using g_application_run().
When I run EWS_DEBUG=2 evolution >& logfile from the command line, I find again this in the logfile:
(evolution:6365): GLib-GIO-WARNING **: 09:14:19.152: Your application did not unregister from D-Bus before destruction. Consider using g_application_run().
Furthermore, the only error message I see in the logfile is repeatedly this one:
< HTTP/1.1 401 Unauthorized
< Soup-Debug-Timestamp: 1676535586
< Soup-Debug: ESoapMessage 1 (0x561a47442770)
< Server: Microsoft-IIS/10.0
< request-id: ce85ae3c-6a4f-42f0-b76b-5119912db12a
< WWW-Authenticate: NTLM TlRMTVNTUAACAAAABgA…. And more
< X-OWA-Version: 15.1.2507.17
< WWW-Authenticate: Negotiate
< X-Powered-By: ASP.NET
< X-FEServer: MSX-L322
< Date: Thu, 16 Feb 2023 08:19:45 GMT
< Content-Length: 0

I run:
Ubuntu 22.04.1 LTS
Gnome 42.5.

Any help is greatly appreciated.
Best regards

by any chance, did you enable Power Saving mode in the system? That can
cause what you see. The synchronization is supposed as an expensive
operation, using a lot of power, thus it’s not done when the Power
Saving mode is enabled. At least in your version. Newer versions have
it changed.

By the way, the calendar runs on the evolution-calendar-factory side.
That’s why you do not see any related output when running evolution
with EWS debugging on. No log needed from it, at least for now.

Dear Milan,
looks like that was it, turned to full power and the sync went through…
Thanks so much for your help!
Best regards

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.