[Evolution] can't sync gmail: "name is not activatable"

Hello,

I want to use Evolution as my email client for Gmail, but when I create the account in Evolution, after having entered my password in the pop-up window where Google asks for it, and having authorized Evolution to access my box, I get a message like this:

Failed to obtain access token from address “https://oauth2.googleapis.com/token”: The name is not activatable

I am on Fedora 39 and Evolution is 3.50.3. I have tried several times, I have uninstalled/reinstalled Evolution and purged the cache in ~/.cache but every time I get the same error. I tried with Thunderbird, and had no trouble setting up the account.

Can anybody help me? Thanks!

Hi,
it looks like the libsecret cannot talk to its counterpart over D-Bus,
which is usually gnome-keyring-daemon.

Could you run seahorse (it’s called “Passwords and Keys” in the desktop
environment) and check it can access the Passwords section, please?

I do not know what spin of Fedora 39 you use, but at least the
Workstation with GNOME Shell does have installed the gnome-keyring
package, which provides the daemon.
Bye,
Milan

Thanks for your answer, I installed the keyring with “dnf install gnome-keyring”, and I could get my mail from Gmail!

Problem solved!