Evolution Calendar keeps asking for password

I recently upgraded from Debian 10 to Debian 12.5. I frequently run “apt-get update” My window manager is KDE Plasma 5.27.5 and KDE Frameworks 5.103.0.

The current evolution distributed by Debian is 3.46.4-2.

The Evolution Calendar asks for a password frequently. I insert my mail account password, which it rejects and asks again, until I cancel the request. Then it asks again in about thirty minutes.

I found an article from 2014 that recommended to delete everything from .gnome/keyrings and stop seahorse and reboot and … I haven’t found anything newer that’s relevant. I haven’t tried the recommended process. I looked at the login keywords using the seahorse GUI. Most of the Evolution ones have cryptic names like “Evolution Data Source 1172819241.4577.12@van.home” None of them have the word “calendar” in them.

How do I either make it stop asking, or change the password, or get it to accept the mail password?

Hi,
how was the calendar created, please? What is the calendar type? From
that you use a password for the mail account (not calendar), I suppose
the calendar is somehow connected to the mail account, maybe hosted on
the same server.

The thirty minutes interval probably reflects the Refresh interval
you’ve set for the calendar.

Problems with password are usually related to the gnome-keyring-daemon
process, unless something else broke. It also depends what reason the
server returns, with an info why it rejected the credentials, but such
information is not always provided. You can find multiple queries
related to the gnome-keyring-daemon, much newer than from 2014.

I would try to restart the background processes, maybe it’ll help,
maybe not. You can do it from a terminal with:

$ evolution --force-shutdown

You might want to restart the gnome-keyring-daemon first. How’s that
done I do not know. Simply killing the process should be enough.

To see the communication between the calendar and the server, you need
to know what calendar type it is, then you can enable debugging for the
evolution-calendar-factory process as described here:

The logs contain raw data passed between the server and the client,
including credentials in some case. Do not share it anywhere.

Bye,
Milan

| mcrha
June 18 |

  • | - |

Hi,
how was the calendar created, please?

It came into existence automatically, without me having done anything explicit, when I first installed Evolution on Scientific Linux (a RedHat derivative from Fermilab) about twenty years ago. I have never used it. I assume it has just kept going through the multiple versions of Scientific Linux, RedHat, Fedora, Ubuntu, and Debian that I have installed without destroying my home partition.

What is the calendar type?

I have no idea.

From
that you use a password for the mail account (not calendar), I suppose
the calendar is somehow connected to the mail account, maybe hosted on
the same server.

I have never used the calendar, and have no idea where it is hosted.

$ evolution --force-shutdown

You might want to restart the gnome-keyring-daemon first. How’s that
done I do not know. Simply killing the process should be enough.

To see the communication between the calendar and the server, you need
to know what calendar type it is, then you can enable debugging for the
evolution-calendar-factory process as described here:

I have no idea what type the calendar is. I have never used it.

GitLab
### Debugging · Wiki · GNOME / evolution · GitLab

Welcome to GNOME GitLab

The logs contain raw data passed between the server and the client,
including credentials in some case. Do not share it anywhere.

I set the CALDAV_DEBUG environment variable in the Properties for the icon in my KDE task bar. The GitLab page doesn’t say where the logs and debugging output are sent so setting it might have been pointless.

Hi,
in that case, if you do not need it, then I suggest to just drop it.
You can see all of I asked for in the Edit->Accounts, where you can
also disable that calendar.
Bye,
Milan

Under Edit → Accounts, the buttons other than “Add” are grayed-out when I select “Calendars.” Is there another way to delete the calendar or turn it off?

The evolution pop-up to request the calendar password says the calendar is hosted by caldav.calendar.yahoo.com. I can login there, but there’s nothing about setting my password, and in particular nothing special about it needing a different password from my mail password.

Evolution is happy to display a calendar, but I added an event at caldav.calendar.yahoo.com, and Evolution doesn’t show it. If I enter an event in the Evolution calendar, it doesn’t appear at caldav.calendar.yahoo.com

Hi,
“Calendars” is a group, while you want to disable a single calendar.
Expand all the groups and search for that specific calendar. Note it
does not need to be only under the “Calendars” group, it can be under
other accounts, because some accounts are “collection accounts”, which
offer multiple types of the sources by a single configuration, like
when a user creates an Exchange Web Services (EWS) accounts, he/she get
mail, calendars, contacts, tasks and memos by it, not only mail. Such
EWS account has its own group in the Edit->Accounts.

There is also a chance the calendar is part of an account configured in
GNOME Online Accounts. In such case open the system Settings->Online
Accounts and open properties for that account and choose which parts
should be enabled for it.
Bye,
Milan

My account is at sbcglobal.net, which is served by yahoo.com. The calendar is at caldev.calendar.yahoo.com. There’s nothing on that page about a password, and especially not about a special password for the calendar that’s different from the email account password. I can access the calendar in Firefox. I can change it in Firefox. The changes do not appear in the Evolution calendar. I can change the calendar in Evolution, even without Evolution having accepted the password, but the changes do not appear when I look at the calendar in Firefox.

Selecting a “Calendar” item under an account, or the “Calendars” group, on the Edit → Accounts pop-up, grays out the buttons, especially the “Delete” button.

Although it’s installed by default by the Debian installers, I’ve never used the Gnome desktop. There’s no Settings → Online Accounts button in the KDE Plasma system settings widget.

Is there a Gnome program I can run from XTerm to manage the settings?

Selecting a “Calendar” item under an account, or the “Calendars”
group, on the Edit → Accounts pop-up, grays out the buttons,
especially the “Delete” button.

Hi,

okay, then it is part of the Yahoo! account and you entered it in the
Evolution directly. There’s nothing to be done in the Online Accounts
then.

You cannot delete those sources (calendars), but you can disable them.
Simply uncheck the box in the “Enabled” column.

Does that Yahoo! account show up on its own in the Edit->Accounts or
it’s under the Mail Accounts node? If the former, you can select it and
click on the Edit button and disable all the calendars from there.

If you’d like to complete get rid of the calendar (and contacts) from
the Yahoo! account, then just configure a new mail account for that
address and at the very end do not check to add also calendars and
contacts. I guess that’s how it has got into your account.

The changes do not appear in the Evolution calendar. I can change
the calendar in Evolution, even without Evolution having accepted
the password, but the changes do not appear when I look at the
calendar in Firefox.

That’s expected behavior, as far as I can tell.
a) without password, you cannot read server-side content;
b) without password, you cannot write to the server, but the calendars
can do changes offline and save them once the calendar is connected,
thus the change had been accepted locally and is waiting for
a successful connection to the server to save it there;
c) even with password, the server changes are not recognized
automatically, because CalDAV has no such thing, thus they’d show up
the next time the periodical refresh is done or when the calendar
is refreshed manually.

I think Yahoo! changed something on their side, they might enforce
OAuth2 and disable password-based logins on the calendar. Newer version
of Evolution should work fine, maybe also yours, though it might need
to change the Authentication type in the Mail account to use the same
method, the “OAuth2 (Yahoo!)”. The calendar derives the authentication
type from the Mail account. Anyway, this is only a guess. The password
prompt may contain a reason for the password rejection, or it can be
seen in the CalDAV log of the evolution-calendar-factory process, if
provided by the server.
Bye,
Milan