Epiphany/Web Can't print or print to file

I’m unable to print web pages from the Epiphany (aka Web) browser. When I try to print I get a “Printer not found” message . When I try to print to file, I get “Error opening file…No such file or directory.”

Printing works fine with Firefox. I’m running Gnome 3.38.4 on opensuse tumbleweed.

I’d be grateful for any advice.

1 Like

If you’re using the flatpak, then it’s known.

Hmm, I installed Epiphany from opensuse’s tumbleweed repository. I didn’t use flatpak.

1 Like

Just tried print to a file in epiphany (installed from fedora repository), and get the same error message.

1 Like

This is a webkit bug. Refer https://gitlab.gnome.org/GNOME/epiphany/-/issues/1377

Workaround: ( not recommended )

Start epiphany as:



1 Like

That works, thank you. Now epiphany can print to file and print to the printer. Is there any way to disable sandbox so that epiphany can be launched with the workaround without using the command line?

BTW, I really like using Epiphany. It has become my day-to-day browser. Beautiful interface, and nice gesture navigation.

Refer https://gitlab.gnome.org/GNOME/epiphany/-/issues/1377#note_1036040

Thanks–I should have looked at that page more carefully. I edited /usr/share/applications/org.gnome.Epiphany.desktop and added the following line, as suggested:
Exec= env WEBKIT_FORCE_SANDBOX=0 epiphany %U
(I also commented out the existing Exec= line)
Now printing works in Epiphany without having to use the command line workaround.
One last quick question: Is there any drawback to leaving sandbox disabled?

That’s a question for epiphany / webkit devs.


There’s a bit of explanation here.

Thanks for the link to that interesting blog. Now I’m thinking that I should revert to Epiphany’s default settings and use Firefox (or the command-line workaround) when I need to print.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.