Epiphany cannot find Cairo

While trying to build Epiphany I receive:

Found pkg-config: /usr/bin/pkg-config (0.22)
Run-time dependency iso-codes found: YES 3.12.1
Found CMake: /usr/local/bin/cmake (3.19.2)
WARNING: CMake Toolchain: Failed to determine CMake compilers state
Run-time dependency cairo found: NO (tried pkgconfig and cmake)

meson.build:80:0: ERROR: Dependency “cairo” not found, tried pkgconfig and cmake

A full log can be found at /media/34GB/Arquivos-de-Programas-Linux/meson-logs/meson-log.txt

I need to pass the Cairo dir to it. With configure that is as easy as putting: PKG_CONFIG_PATH=/media/34GB/Arquivos-de-Programas-Linux/Cairo-1.10.0/lib/pkgconfig/ together with the configure command.

Here: meson.py .. PKG_CONFIG_PATH=/media/34GB/Arquivos-de-Programas-Linux/Cairo-1.10.0/lib/pkgconfig/ does not work.

How to proceed then?

Epiphany does not use CMake and it doesn’t (directly) depend on cairo either. What are you really trying to build?

meson can use cmake to detect dependencies

the 2nd argument to meson is the build directory. so that will probably try to build epiphany in a folder ./PKG_CONFIG…
please try writing the PKG_CONFIG_PATH assignment before the meson executable

1 Like

Hi. It didn’t change the outcome.