Enabling dark style does nothing (GNOME 44, NixOS 23.11)

A while ago I played around with some mind mapping application. I think it was Freeplane. I selected a color theme and it asked me if I wanted it do adapt my system settings accordingly.
I stupidly agreed and since then all applications are in light theme. I can enable dark mode in the quick settings, the settings → appearance menu or dconf, but none of it has an effect.
It seems like the application changed some setting in a way that is honored by everything, but can’t be changed or isn’t officially supported.
I tried resetting the appearance settings in gnome-tweaks as well as in dconf to no avail.
Anyone got an idea where that setting might be hiding?


This definitely sounds like something that should be reported to the project in question too, they should not do such things.

Is there maybe a ~/.config/gtk-4.0/gtk.css or ~/.config/gtk-3.0/gtk.css that got created by the application?

No. Those files exist, but both only import their respective colors.css, which holds the colors defined by KDE to match its theme. I switch between DEs now and then.

Overriding the colors this way could prevent dark mode from working. Try removing/renaming those files and restarting your session.

rm -vfr .config/gtk* didn’t solve it, I’m afraid. I also checked with Freeplane, they don’t offer such a functionality.
Additionally I tried reproducing the issue in a VM, so I might be able to easily diff two snapshots to find where the change is made, but so far I haven’t been able to reproduce the behaviour with Freeplane or FreeMind.

What is the output of ps ux | grep xdg-desktop-portal? Maybe some non-gnome portal implementation is running that is overriding the dark mode.

$ ps ux|grep xdg-desktop-portal
chais       2472  0.0  0.0 524428  6528 ?        Ssl  11:38   0:00 /nix/store/jc34jhq5p54ycsryjbbwswmnm1v5s7np-xdg-desktop-portal-1.16.0/libexec/xdg-permission-store
chais       2966  0.0  0.0 763716 14976 ?        Ssl  11:38   0:00 /nix/store/jc34jhq5p54ycsryjbbwswmnm1v5s7np-xdg-desktop-portal-1.16.0/libexec/xdg-desktop-portal
chais       2976  0.0  0.0 748200  6528 ?        Ssl  11:38   0:00 /nix/store/jc34jhq5p54ycsryjbbwswmnm1v5s7np-xdg-desktop-portal-1.16.0/libexec/xdg-document-portal
chais       2985  0.0  0.0 920192 27776 ?        Ssl  11:38   0:00 /nix/store/d3ab1d7h5gw37dvw2cl31rl8s3ji6c9g-xdg-desktop-portal-gnome-44.1/libexec/xdg-desktop-portal-gnome
chais       3007  0.0  0.0 630352 24964 ?        Ssl  11:38   0:00 /nix/store/rzpzhk9rx5fv601g7cxf72vs05dzhwj7-xdg-desktop-portal-gtk-1.14.1/libexec/xdg-desktop-portal-gtk

Nope. Only gnome, GTK and the base-implementation.

Checking Nautilus with the inspector got me this:
Not sure if the unset GTK theme could be cause of effect of the lack of a dark theme. It’s not like that in a fresh install, at least. Any idea how to fix it?

That was the hint I needed. I had a GTK_THEME variable set in a config file in .config/environment.d. Once I deleted the file and restarted gnome the dark theme started working again.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.