Empty boxes after re-installation & copy of images inside

Good evening :slightly_smiling_face:,

After reinstalling my system and Boxes on a larger SSD, I pasted in the “image” folder of the latter, the various images of Windows 10 that I had saved. However, when I launch Boxes, there are no virtual machines inside.

What is the solution please?

Placing the images inside is not enough. You need to create a new virtual machine from that image for it to be managed by Boxes. Go to + → “Create virtual machine from file”.

Hello felipeborges :slightly_smiling_face:,
Thank you for your feedback.
When I create a new machine, I cannot access the image in : \directory personnel.local\Share\Gnnmes-Boxes\images. I thus select the iso of safeguard. The return is "operating system not recognized.

Sorry, I didn’t realize that we could do the following. So it works, but on a DD? not on the SSd of my system! How to access it please?

I did it! Since hidden files are enabled in Dolphin, I didn’t understand why I couldn’t see them in the contextual window of the machine creation. I right-clicked and made them appear.

Two problems though :

1) Although there are no pictures in the machine, I can’t increase its size: it is grayed out.

2) Boot failled : not a bootable disk ! While on my DD it worked. An island ?

Hello,
After a bit of poking around, I realized that I had two images with the same name, but not the same size. So, the W10 virtual machine works fine.

However, even without snapshots, I still can’t increase the size of the latter manually, thanks to the +, it is grayed out.
I notice that the system modification file, does not contain the image size. Is this normal?

Thank you for your suggestions.

<domain type="kvm" id="3">
<name>boxes-unknown</name>
<uuid>0ebdadbf-6266-41e4-8cdd-50eb8cf07c5d</uuid>
<title>win10-6</title>
<metadata>
<boxes:gnome-boxes xmlns:boxes="https://wiki.gnome.org/Apps/Boxes">
<os-state>installed</os-state>
<media>/home/sl/.local/share/gnome-boxes/images/win10-6</media>
</boxes:gnome-boxes>
<edited:edited xmlns:edited="https://wiki.gnome.org/Apps/Boxes
edited">2023-01-12T11:33:52+0100</edited:edited>
</metadata>
<memory unit="KiB">10485760</memory>
<currentMemory unit="KiB">10485760</currentMemory>
<vcpu placement="static">8</vcpu>
<os>
<type arch="x86_64" machine="pc-i440fx-7.2">hvm</type>
<boot dev="hd"/>
<bootmenu enable="no"/>
</os>
<features>
<acpi/>
<apic/>
</features>
<cpu mode="host-passthrough" check="none" migratable="on">
<topology sockets="1" dies="1" cores="4" threads="2"/>
</cpu>
<clock offset="localtime">
<timer name="rtc" tickpolicy="catchup"/>
<timer name="pit" tickpolicy="delay"/>
<timer name="hpet" present="no"/>
</clock>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>destroy</on_crash>
<pm>
<suspend-to-mem enabled="no"/>
<suspend-to-disk enabled="no"/>
</pm>
<devices>
<emulator>/usr/bin/qemu-system-x86_64</emulator>
<disk type="file" device="disk"><driver name="qemu" type="qcow2" cache="writeback"/>
<source file="/home/sl/.local/share/gnome-boxes/images/win10-6" index="2"/>
<backingStore/>
<target dev="hda" bus="ide"/>
<alias name="ide0-0-0"/>
<address type="drive" controller="0" bus="0" target="0" unit="0"/>
</disk>
<disk type="file" device="cdrom">
<driver name="qemu"/>
<target dev="hdc" bus="ide"/>
<readonly/>
<alias name="ide0-1-0"/>
<address type="drive" controller="0" bus="1" target="0" unit="0"/>
</disk>
<controller type="usb" index="0" model="ich9-ehci1">
<alias name="usb"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x7"/>
</controller>
<controller type="usb" index="0" model="ich9-uhci1">
<alias name="usb"/>
<master startport="0"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x0"
multifunction="on"/>
</controller>
<controller type="usb" index="0" model="ich9-uhci2">
<alias name="usb"/>
<master startport="2"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x1"/>
</controller>
<controller type="usb" index="0" model="ich9-uhci3">
<alias name="usb"/>
<master startport="4"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x2"/>
</controller>
<controller type="pci" index="0" model="pci-root">
<alias name="pci.0"/>
</controller>
<controller type="ide" index="0">
<alias name="ide"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x01" function="0x1"/>
</controller>
<controller type="virtio-serial" index="0"><alias name="virtio-serial0"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x07" function="0x0"/>
</controller>
<controller type="ccid" index="0">
<alias name="ccid0"/>
<address type="usb" bus="0" port="1"/>
</controller>
<interface type="user">
<mac address="52:54:00:93:2a:1b"/>
<model type="rtl8139"/>
<alias name="net0"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x03" function="0x0"/>
</interface>
<smartcard mode="passthrough" type="spicevmc">
<alias name="smartcard0"/>
<address type="ccid" controller="0" slot="0"/>
</smartcard>
<serial type="pty">
<source path="/dev/pts/1"/>
<target type="isa-serial" port="0">
<model name="isa-serial"/>
</target>
<alias name="serial0"/>
</serial>
<console type="pty" tty="/dev/pts/1">
<source path="/dev/pts/1"/>
<target type="serial" port="0"/>
<alias name="serial0"/>
</console>
<channel type="spiceport">
<source channel="org.spice-space.webdav.0"/>
<target type="virtio" name="org.spice-space.webdav.0" state="connected"/>
<alias name="channel0"/>
<address type="virtio-serial" controller="0" bus="0" port="1"/>
</channel>
<channel type="spicevmc">
<target type="virtio" name="com.redhat.spice.0" state="connected"/>
<alias name="channel1"/>
<address type="virtio-serial" controller="0" bus="0" port="2"/>
</channel>
<input type="mouse" bus="ps2">
<alias name="input0"/></input>
<input type="keyboard" bus="ps2">
<alias name="input1"/>
</input>
<graphics type="spice">
<listen type="none"/>
<image compression="off"/>
<gl enable="no"/>
</graphics>
<sound model="ich6">
<alias name="sound0"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x04" function="0x0"/>
</sound>
<audio id="1" type="spice"/>
<video>
<model type="qxl" ram="65536" vram="65536" vgamem="16384" heads="1" primary="yes">
<acceleration accel3d="no"/>
</model>
<alias name="video0"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x0"/>
</video>
<redirdev bus="usb" type="spicevmc">
<alias name="redir0"/>
<address type="usb" bus="0" port="2"/>
</redirdev>
<redirdev bus="usb" type="spicevmc">
<alias name="redir1"/>
<address type="usb" bus="0" port="3"/>
</redirdev>
<redirdev bus="usb" type="spicevmc">
<alias name="redir2"/>
<address type="usb" bus="0" port="4"/>
</redirdev>
<redirdev bus="usb" type="spicevmc">
<alias name="redir3"/>
<address type="usb" bus="0" port="5"/>
</redirdev>
<memballoon model="virtio">
<alias name="balloon0"/>
<address type="pci" domain="0x0000" bus="0x00" slot="0x06" function="0x0"/>
</memballoon>
</devices></domain

Hello :grinning:,
A little help please ? :worried: