Disabling touch mode


Hope to be in the right place with my post (sorry if not). I have a problem with a fleet of Epson beamers (695wi and newer). It goes automatically into touch mode. This mode is very interesting except that it does not work as well as it should work (random click, gesture rarely understood by the system etc.)! Maybe it’s an hardware or driver problem (695wi) ??? Anyway this problem occur with all wi beamers i tried (newer than 695) and my users can’t use their computers like this.

Do you have an idea of how to avoid this mode while still keeping the touch function of my screen (working like a mouse) ?

Thank you for your help.

I found a solution that worked for me. Thanks to :

If I disable the hid_multitouch driver the beamer is not recognized as a touch screen by the system but as a mouse. This does not enable the touch mode.


create the file hid_multitouch.conf in /etc/modprobe.d

Inside the file :

# Use the following syntax
# blacklist driver-name
blacklist hid_multitouch

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.