Disabling on-screen keyboard

Hi,

There’s no obvious way to disable on-screen keyboard in GNOME 42.

I’m using desktop with dual screen, and one of it is a touch monitor. The desktop has a keyboard with trackpoint attached to it. GNOME thinks that OSK should be displayed even with keyboard attached, unlike in 2-in-1 laptop such as thinkpad yoga where OSK is only displayed when keyboard+trackpoint are disabled in tablet mode. To make things worse, the OSK tend to appear on the main screen that does not have touch, creating a very frustrating workflow.

Should I file this as a bug? … I’m seeing many people asking how to do this online, with no real solution except for some outdated solution such as Block Caribou extension, which does not work in GNOME 42 as it is not using caribou.

Update:

It is a bug … Disable on-screen keyboard if there is physical keyboard connected (#6302) · Issues · GNOME / gnome-shell · GitLab