Disable the fading in mutter whenever there's a framedrop

I’m running Fedora 39 (and it also happens on Nobara as well). Whenever there is what I presume is a framedrop, instead of dropping the frame cleanly, it performs a smooth fade effect between the two frames. When playing games or video, this becomes very annoying. Is there any way to disable this? It happens specially when the Night Light mode is on (at least on my laptop).

It happens on both, my laptop and my desktop. The laptop is running a dual-GPU setup (i5 11400h + RTX 3060) and my desktop is fully AMD-based (Ryzen 7 3700x + Radeon 6700XT), so this is not due to Nvidia.

Dropping what frames? There is no “smoothing” between dropped frames anywhere that I know of. An app dropping frames has no smoothing, and the shell itself can’t “smooth” dropped frames since it was itself that dropped a frame.

This was determined to be an extension issue: Add a gsettings option to disable the fading in mutter whenever there’s a framedrop (#3311) · Issues · GNOME / mutter · GitLab

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.