Desktop icons display

I’ve recently installed GNOME (debian ARM buster) for a user and the *.desktop entries weren’t displaying. I found the option in Tweak tool to enable the display but now all the files in the Desktop directory are shown twice. The proper display has entries I can click to launch. The erroneous display has large icons (all indicating text files) with the full filename underneath. I cannot select these erroneous entries.
It looks like I have two processes adding the entries to the screen. One works properly and the other doesn’t.
Can anyone suggest how I can fix this ? Or what processes the Tweak tool option (Icons on Desktop) invokes ?


1 Like

Replying to my own question here:
The good desktop icons are from Cinnamon which is also installed on this PC.
The bad icons (text doc icons) are from Gnome.
All these icons appear only when “Show desktop icons” (Tweak option) is enabled.

My solution is to disable the Tweak option and then add a .desktop entry to ~/.config/autostart.
The desktop entry command is “nemo --no-default-window --force-desktop”.

I’m using the Tweak extension “Application menu”. Can anyone tell me where these menus are stored and how I can modify them. One particular need is to modify the Vivaldi command so the root user can run it.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.