Delete key not working

In May 2020, I migrated from debian stable to debian testing by updating the apt sources list. Since then, my delete key is not working in Gnome (it works in LXDE). Instead of deleting the next character it prints, depending on the program, nothing or an underlined <007F> character (see video). The first and second press of the key add this symbol, the third press resets. When I press another key after the first press of the delete key, the charactor gets either an accent, a grave accent or a cedille, depending on the character (e.g. DEL+w becomes ẃ, DEL+e becomes è and DEL+v becomes ṿ).

Versions:

  • Linux 5.10.0-3
  • OS: Debian Testing
  • GNOME: 3.38.3
  • Windowing System X11 (7.7)
Video of the behavior

Output of xev on delete key
KeyPress event, serial 34, synthetic NO, window 0x5800001,
    root 0x7a7, subw 0x0, time 39222920, (145,86), root:(190,195),
    state 0x0, keycode 119 (keysym 0xffff, Delete), same_screen YES,
    XLookupString gives 1 bytes: (7f) ""
    XmbLookupString gives 1 bytes: (7f) ""
    XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x5800001,
    root 0x7a7, subw 0x0, time 39222983, (145,86), root:(190,195),
    state 0x0, keycode 119 (keysym 0xffff, Delete), same_screen YES,
    XLookupString gives 1 bytes: (7f) ""
    XFilterEvent returns: False

I hope this is the right place to open the issue, I was refered to the forum from the gnome gitlab.

You can do the following:

  1. Create a new user, login to GNOME session and see if the issue shows up ( Xorg and Wayland )

  2. Run the following command and paste the output here:

    $ setxkbmap -print -verbose 10

Thanks!

Okay, apparently the delete key is works again when I log into the other user. And interestingly enough, when I log back into my usual user, the delete key continues to work until the next reboot. Unfortunately, the output of setxkbmap is the same regardless of whether the delete key is working:

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     de,de,us
variant:    neo,,
options:    lv3:ralt_switch
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwertz)
types:      complete
compat:     complete+caps(caps_lock)+misc(assign_shift_left_action)+level5(level5_lock)
symbols:    pc+de(neo)+de:2+us:3+inet(evdev)+level3(ralt_switch)
geometry:   pc(pc105)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete+caps(caps_lock)+misc(assign_shift_left_action)+level5(level5_lock)"	};
	xkb_symbols   { include "pc+de(neo)+de:2+us:3+inet(evdev)+level3(ralt_switch)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

I did not test on Wayland yet because I don’t have it installed and the issue seems to be with my user’s configuration.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

I found the solution today, the problem was not in GNOME, but in IBus.
Deleting the cache file in ~/.cache/ibus/compose/ fixed the issue for me.