Deja-dup no longer works with S3fs

After the removal of the S3 backend, one option to take S3 backups was to use s3fs which mounts a bucket to a local disk (see here).

Unfortunately, due to the introduction of the available size check, when I try to take a new back up I get a “Backup location is too small”. This is probably because my mount reports a free size of 4GB:
df -h --total /my/mount/point
Filesystem Size Used Avail Use% Mounted on
s3fs 4.0G 0 4.0G 0% /my/mount/point
total 4.0G 0 4.0G 0% -

I’ve recently updated from Ubuntu 22.04 to 24.04 and I can no longer take system back ups due to this. Is there any way we can make this check optional or skip it if the underlying filesystem is s3fs?

Turns out that the issue can be overcame by passing a -o bucket_size=64PB option on the s3fs mounting command. See S3FS repo issue for more details: Can one increase the reported available space on mount? · Issue #2489 · s3fs-fuse/s3fs-fuse · GitHub

I think we can close this issue and hope that others will find useful. It would also be awesome if the Deja-dup devs keep in mind users who utilise s3fs integrations as a replacement of the legacy AWS S3 storage option. Though I appreciate it’s no longer officially supported, it’s an integration currently used by many users.

Thanks for the work you put on this.

1 Like

Thank you for the post and the solution!