Déjà Dup backup to Google Drive is not automatic and doesn't remeber the password

Hello! My backups with deja-dup are successful in that they finish without error messages and the files are added to the cloud storage, but they are not taking place automatically, and I have to interact with the app multiple times every backup:

  1. Click the back up now button to start it, even though the auto back up switch is on
  2. Allow access to my Google Drive account
  3. Enter password, even though I switch on remember password every time
  4. Allow access to my Google Drive account, again
  5. (The app checks my files and backs them up)
  6. Allow access to my Google Drive account, again
  7. (The app checks the backup)

This is Déjà Dup 45.1 from Flathub, running on Arch Linux with GNOME 45, but the behavior is not new. I don’t remember if it worked before I forgot the password (I don’t use this computer every day), but then I removed the old backup, changed the password, and there was this error. I found a way of adding ~/.dropbox-dist and ~/.dropbox-dist.backup to the do-not-back-up folder list, but the error persisted. The Google Drive account is personal, not institutional. The account is set with Google as part of a family, but each family member has their own account.

I gather this is not intended app behavior, right? Any idea on what to check, so that I can find out what’s wrong?


Hello! Sorry that Deja Dup is giving you hassle.

  1. No automatic backup. That’s interesting. In GNOME’s Settings app, in the Apps section and then under Backups, you should see the various flatpak permissions enabled. Is “Run in background” on?

  2. Not remembering your password. That sounds like we are having issues saving your password in libsecret. There’s another Arch user that just mentioned having an issue in this ticket here (they aren’t using flatpak though - but there are other users in that ticket with flatpak): DejaDup keeps prompting for encryption password · Issue #7 · flathub/org.gnome.DejaDup · GitHub – I give some ideas of how to investigate (like using Key Rack) – any luck with that?


“Run in background” is on

When I run deja-dup from the terminal, standard error shows a lot of “invalid password returned from portal” messagens from BackendOAuth.vala:174, Operation.vala:286 and CommonUtils.vala:628 (among others?)

When I run keyrack from the therminal, deja-dup does show up. I click it, then keyrack moves from listing apps to showing deja-dup specifics, but it just keep loading the keys for ever. Meanwhile, standard error shows:

Found invalid entry in keyring: Invalid item: MacError. Property names: ["client_id"]
Found invalid entry in keyring: Invalid item: MacError. Property names: ["owner", "type"]


I installed Manjaro to try to get an Arch system that might reproduce this. I installed the flatpak version of deja-dupk but no luck so far.

“invalid password returned from portal” - this error is interesting. It’s coming from libsecret when talking to the secrets portal, when it gets a message it doesn’t understand. Do you know if you’re running gnome-keyring-daemon in your session?

I don’t know what to do with the “Found invalid entry in keyring” message… it’s not familiar to me and I don’t see any similar references when searching online.

$ systemctl --user list-units | grep keyring
  gnome-keyring-daemon.service                                                             loaded active running   GNOME Keyring daemon
  gnome-keyring-daemon.socket                                                              loaded active running   GNOME Keyring daemon

Once upon a time I forgot my password, and fumbled with seahorse / Passwords and Keys to try to find out my password and, failing that, set a new one.

After your message, I deleted the org.gnome.DejaDup entry with seahorse, and ran $ flatpak run org.gnome.DejaDup again. No error messages this time! it only asked me once for Google autentication and once for my password. Already ran a second backup just in case, and it didn’t ask me for anything!

Now that the password problem was resolved, I presume the backups will be done automatically. I will report back in case they don’t.

Thanks for the help (and Déjà Dup)!

1 Like


The entry in Seahorse may have looked odd. That’s because flatpak apps store their secrets a little oddly. You can use Key Rack to look at them in a more sensible format in the future: Key Rack | Flathub

And in your case, the secrets file must have gotten corrupted / confused somehow. And deleting it “solved” it.

That’s a good clue for future uses / other folks seeing this. Please let me know if this happens again!

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.