Connect to NFS server with Nautilus

Hey guys,

My name is Felipe and I’m a user of Ubuntu 22.04 at home and ZorinOS at work, unfortunately I’m not a developer, but I hope to help the community in any way I can.

Let’s get to the problem, I have a Debian Server running “nfs-kernel-server” which is working perfectly, but when I try to map the NFS using nautilus I am unsuccessful because it tries to start the connection with high ports, and apparently

it does not accept me to configure the port (nfs://myserver:port/share) and the response I receive from my server is: (refused mount request from 172.19.1.130 to /share (/share): illegal port 53820) .

I see that it is not a problem with my NFS server, because when connecting via terminal using the command (mount.nfs horizon:/share /NFSSHARE/ it works as expected.

Can you help me solve this problem?

Thank you in advance for everyone’s attention.

There are two ways to fix that:

  • Allow non-system ports for connecting to the server by using the insecure option in /etc/exports
  • Allow gvfs daemon to use system ports over sudo setcap 'cap_net_bind_service=+ep' /usr/libexec/gvfsd-nfs.

@oholy Thank you very much for the tips,

I applied the second option (Allow gvfs daemon to use system ports ), as I thought it was safer.

Could you explain to me in more detail where these settings were stored?

I’m a noob in Linux systems and I’m trying to deepen my knowledge, if that’s the case, could you just tell me where I should start to understand what I did in this command?

Anyway THANK YOU VERY MUCH, it helped a lot.

Take a look at the man capabilities output (or capabilities(7) - Linux manual page).