Configuring for video_ts + problem with titles

From the change log i see that rygel supports streaming video_ts directories, but i have not been able to make it work.
I get the following output when starting rygel:

Rygel-Message: 23:37:27.358: Rygel v0.38.3 starting…
RygelCore-Message: 23:37:27.377: New plugin “Playbin” available
RygelCore-Message: 23:37:27.448: New plugin “MediaExport” available
MxExtract-Message: 23:37:27.546: rygel-media-export-extract.vala:180: Started with descriptors 3 (in) 4 (out)
MediaExport-Message: 23:37:27.568: “file:///share” harvested
MediaExport-Message: 23:37:27.574: rygel-media-export-harvesting-task.vala:309: Harvesting of file:///share done in 0,046489

I haven’t found any explicit instructions in the documentation, but maybe it has to do with gstreamer or MediaExport? Other videos are visible, but no video_ts dvds.

Another problem i have been experiencing is that some videos get strange and nondescript titles like “English” or “Surround”,

i suspect this is because the files have empty title metadata fields. If this is the case, is there any way to configure it to use the filename as title?


1 Like

Yeah sorry, that needs more documentation. For that to work, you need to have the “dvdread” binary installed and GStreamer ugly plugins for gstdvdreadsrc. Beware that seeking on those files only works with clients that support time-based seeking (tested by me are LG DVD players and the Sony PS4 media player)

It also works best with single-title DVDs - if you have multiple titles (extra scenes, commercials, etc.) you will end up with loads of movies you cannot distinguish :-/

That is from MKV files I suppose? There’s a bug open and I’m not sure if GStreamer is giving me something wrong (it concatenates all stream names together) or if I’m using it wrong. ( and

You can use filenames as titles if you disable meta-data scanning completely.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.