Compressed Files creating folders

Hi everyone, I’m using Fedora 32. I’d like to know where do I prevent nautilus from creating a folder when I open a zip file, or tar.gz file. That really annoys me! From blog posts, to everything else people seems to enjoy it, but to me it’s waste of time. I could not find it in the preferences of nautilus, does anybody knows where I can change this behavior?

Thanks!

1 Like

You could change the handler to Archive Manager instead of Files, then double click will launch Archive Manager to inspect the archive instead of extracting it

Properties ⟶ Open With ⟶ Archive Manager ⟶ Set as default

Note you’ll have to repeat that for each archive type