Chrome Remote Desktop does not work on Ubuntu 22.04.3 LTS

  • Environment of the remote machine: Ubuntu 22.04.3 LTS, Chrome 122.0.6261.94 (Official Build) (64-bit), Chrome Remote Desktop version 2.1.
  • Environment of the local machine: Windows 10, FireFox 123.0 (64-bit).

I followed instructions in this webpage to try to remote connect to a GNOME desktop of a Ubuntu machine. Specifically, I have installed the 64-bit Debian package chrome-remote-desktop_current_amd64.deb. I have installed the Chrome Remote Desktop extension to Chrome browser and turned it on. I have created the ~/.config/chrome-remote-desktop directory. I have turned on the Chrome Remote Desktop by clicking the blue “Turn on” button and set up the password. But when I tried to connect to it, I saw the following session chooser window but I couldn’t select any session because the mouse and keyboard did not work.

enter image description here

If I follow instructions in “Use Chrome Remote Desktop on Linux” of the webpage by creating .chrome-remote-desktop-session file in my home directory with the contents (env ... is the Exec command in /usr/share/xsessions/ubuntu.desktop):

exec /etc/X11/Xsession env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session --session=ubuntu

I will see this:

enter image description here

Again mouse and keyboard does not work and the remote machine can login in only with X11 window system (if with Wayland, I cannot login with repeated login screen).

How to fix this problem?

How can I delete my question, if I don’t have to wait for a month?
Or if you are a moderator, can you delete this question? Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.