Change the brightness ratio

Hello everyone, I’m on fedora.

I find that when I press my button to decrease the brightness, the change is too strong. Like if I say no nonsense, every time I go, the brightness decreases by 10% but I would like 5%.

Can you tell me how to change that?

1 Like

I do not think you can configure this on the GNOME shell, but I do think I have a workaround/solution. I do not own a laptop anymore, so I cannot test this out at the moment but I did for years until October of last year, so hopefully this helps.

The xbacklight utility program could solve your problem. You can install it on Fedora, or any RHEL-based distribution, using the command below:

sudo dnf install xbacklight

Then, you can set up a keyboard shortcut for it via GNOME.
The following steps may vary on the version of the shell you are using; I am currently on GNOME 46.1:

  • Open the GNOME Control Center (or search “settings” in the shell menu)
  • Go to “Keyboard.”
  • Scroll down to “Keyboard Shortcuts”.
  • Click on “View and customize shortcuts.”
  • Scroll down and click on the “Custom Shortcuts”, then “Add Shortcut.”
  • Enter a name for your shortcut, e.g., “Decrease brightness by 5%.”
  • In the “Command” field, enter the xbacklight -dec 5 command.
  • Assign a key combination to this shortcut by clicking on “Set Shortcut.”

Hopefully this works out! :slight_smile:

Thanks for your answer, unfortunately I’m on wayland and so xbacklight does not work. I will however look for alternatives for wayland.

Maybe brightnessctl? I’ve never used it, but remember reading of it.

I support that idea.