Change date format to dd/mm/yyyy?

For many of us living outside the USA the mm/dd/yyyy date format can be very confusing. Is there a way to set Geary to dd/mm/yyyy?

1 Like

That is what locales are for ( to use date / money formats specific to your region ).

The locale is set as part of the OS installation / user creation. If that’s not set correctly, you can change the locale in:

'Settings' -> 'Region & Language'

to a more accurate one.

If geary doesn’t reflect your locale preferences ( I guess it does ), you can open an issue.

Thanks!

Seems to be a bug/missing feature. Geary bugs can be reported here

https://gitlab.gnome.org/GNOME/geary/-/issues

Thank you both. I double checked and my locale setting is correct for dd/mm/yyyy format so I have made a bug report. Thanks for the link @sophieherold.

Hi Brian, per the issue you filed, this isn’t a bug in Geary, rather a misconfiguration of your desktop or system somewhere. Unfortunately I’m not familiar with KDE so can’t speak to how it works, but I can say Geary uses GLib and Gettext for internationalisation, and these use environment variables (as set by your desktop environment) to determine the date/time format to use.

It might be worth investigating the environment variables that are set for you (open up a terminal and run locale for example) and compare that with the docs above and what you expect to be set. You can also manually override the variables in a terminal and run Geary from there to easily test different configurations without having to log out and log in again.

You may also want to check you have the appropriate distro language packs installed for your preferred locale. It doesn’t look like you are running Geary installed via Flatpak, but if you are it is probably worth reading the details about that in the Geary FAQ instead.

Sorry I can’t be of more help, but maybe someone here or on KDE forums with a better knowledge of how it works may be able to chip in.

2 Likes

Thank you Michael. Much appreciated. I will follow up on your suggestions. Worth it I think because I do like Geary.

I checked and GLib and Gettext were already present. Locale in terminal showed all correct settings but then BINGO! I installed some outstanding language packs and suddenly the dates are showing as expected. Thanks very much Michael.

You’re welcome! Glad it’s working now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.