Can't connect to a headless Gnome Remote Desktop

Tried setting up the Gnome Remote Desktop on a Fedora 40 LXC container following these instructions: Headless Remote Desktop setup process except the firewall part as it’s not installed.

Can’t connect to the newly set up RDP-server though.

[eugrus@RemoteDesktop ~]$ sudo -u gnome-remote-desktop winpr-makecert -silent -rdp -path ~gnome-remote-desktop rdp-tls
[eugrus@RemoteDesktop ~]$ sudo grdctl --system rdp enable
Init TPM credentials failed because No TPM device found, using GKeyFile as fallback.
Init TPM credentials failed because No TPM device found, using GKeyFile as fallback.
[eugrus@RemoteDesktop ~]$ sudo grdctl --system rdp set-credentials "${RDP_USER}" "${RDP_PASS}"
[sudo] password for eugrus:
Init TPM credentials failed because No TPM device found, using GKeyFile as fallback.
[eugrus@RemoteDesktop ~]$ sudo grdctl --system rdp set-tls-key ~gnome-remote-desktop/rdp-tls.key
Init TPM credentials failed because No TPM device found, using GKeyFile as fallback.
[eugrus@RemoteDesktop ~]$ sudo grdctl --system rdp set-tls-cert ~gnome-remote-desktop/rdp-tls.crt
Init TPM credentials failed because No TPM device found, using GKeyFile as fallback.
[eugrus@RemoteDesktop ~]$ sudo systemctl --now enable gnome-remote-desktop.service
[eugrus@RemoteDesktop ~]$ sudo systemctl status gnome-remote-desktop.service
[sudo] password for eugrus:
● gnome-remote-desktop.service - GNOME Remote Desktop
     Loaded: loaded (/usr/lib/systemd/system/gnome-remote-desktop.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
             /run/systemd/system/service.d
             └─zzz-lxc-service.conf
     Active: active (running) since Mon 2024-06-03 17:01:55 UTC; 27min ago
   Main PID: 2874 (gnome-remote-de)
      Tasks: 4 (limit: 9072)
     Memory: 7.2M ()
        CPU: 107ms
     CGroup: /system.slice/gnome-remote-desktop.service
             └─2874 /usr/libexec/gnome-remote-desktop-daemon --system

Jun 03 17:01:54 RemoteDesktop systemd[1]: Starting gnome-remote-desktop.service - GNOME Remote Desktop...
Jun 03 17:01:55 RemoteDesktop gnome-remote-de[2874]: Init TPM credentials failed because No TPM device found, using GKe>
Jun 03 17:01:55 RemoteDesktop systemd[1]: Started gnome-remote-desktop.service - GNOME Remote Desktop.
Jun 03 17:18:59 RemoteDesktop systemd[1]: Started gnome-remote-desktop.service - GNOME Remote Desktop.
lines 1-18/18 (END)...skipping...
● gnome-remote-desktop.service - GNOME Remote Desktop
     Loaded: loaded (/usr/lib/systemd/system/gnome-remote-desktop.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
             /run/systemd/system/service.d
             └─zzz-lxc-service.conf
     Active: active (running) since Mon 2024-06-03 17:01:55 UTC; 27min ago
   Main PID: 2874 (gnome-remote-de)
      Tasks: 4 (limit: 9072)
     Memory: 7.2M ()
        CPU: 107ms
     CGroup: /system.slice/gnome-remote-desktop.service
             └─2874 /usr/libexec/gnome-remote-desktop-daemon --system

Jun 03 17:01:54 RemoteDesktop systemd[1]: Starting gnome-remote-desktop.service - GNOME Remote Desktop...
Jun 03 17:01:55 RemoteDesktop gnome-remote-de[2874]: Init TPM credentials failed because No TPM device found, using GKeyFile as fallback
Jun 03 17:01:55 RemoteDesktop systemd[1]: Started gnome-remote-desktop.service - GNOME Remote Desktop.

Also, ss doesn’t show anything listening on 3389:

[root@RemoteDesktop ~]# ss -lntl
State           Recv-Q          Send-Q                   Local Address:Port                   Peer Address:Port
LISTEN          0               4096                        127.0.0.54:53                          0.0.0.0:*
LISTEN          0               4096                     127.0.0.53%lo:53                          0.0.0.0:*
LISTEN          0               4096                           0.0.0.0:5355                        0.0.0.0:*
LISTEN          0               4096                              [::]:5355                           [::]:*

GRD works for me when it runs on a physical host or libvirt+KVM guest, even with all graphics removed, however using LXC seems problematic because although I install the same set of packages, make GRD listen on the RDP port, accept client connections, and pass the authentication, but the GDM login screen does not appear, and the client just hangs utilizing 100% CPU.

1 Like