Cannot launch flatpak apps from gnome-shell

After the last flathub update, various apps (i.e org.gnome.Geary, org.gnome.Boxes, org.gnome.Calendar, org.gnome.Evince, org.gnome.eog) got updated on top of gnome 44 runtime.

I am on debian stable and I can no longer launch those flatpaks from gnome shell overview (nor via gtk-launch). No error in the logs, they just don’t open

mar 23 21:26:26 hostname systemd[2289]: Started dbus-:1.2-org.gnome.Boxes@1.service.
mar 23 21:26:26 hostname systemd[2289]: Started app-flatpak-org.gnome.Boxes-65327.scope.
mar 23 21:26:27 hostname systemd[2289]: dbus-:1.2-org.gnome.Boxes@1.service: Succeeded.
mar 23 21:26:27 hostname systemd[2289]: app-flatpak-org.gnome.Boxes-65327.scope: Succeeded.
mar 23 21:26:27 hostname systemd[2289]: app-flatpak-org.gnome.Boxes-65327.scope: Consumed 1.205s CPU time.

They run fine if I run them via flatpak run or even via gnome-software, only overview launcher is affected

Were there any recent changes that could affect launching flatpaks via (pretty old) gnome-shell 3.38 present in debian? I tried to reproduce this issue on debian testing which has gnome-shell 43 and it’s not affected

After some more digging, journalctl with elevated permissions, reports this upon running any of mentioned flatpaks:

kernel: file-roller[75192]: segfault at 40 ip 00007f912c67220c sp 00007fff067ea110 error 4 in[7f912c66f000+8000]

You’re hitting this bug. I’ll add that fix to the 44 runtime now.

1 Like

Um, actually that only explains what’s going wrong for GTK 4 apps. I do not know what is wrong with your GTK 3 apps. You’ll need to collect a backtrace using gdb. Follow these instructions.

1 Like

Thanks Michael, I believe all of the affected apps are gtk4. I’ll post a feedback as soon as the fixed runtime is up in flathub.

No, all of these apps except for Calendar use GTK 3. They won’t be fixed without a backtrace and bug report.

(I’m pretty sure the runtime update will fix your problem with Calendar, though.)

You are right, only the calendar got fixed after the update.

However I think that the same code regarding xdg_activation was merged in gtk3 in version 3.24.37 (which is now present in both org.gnome.Platform 43 & 44):

So I think everything will start working again if this is patched as well.

Oh, quite possibly yes. We can try that, sure.

Without a backtrace, it’s just a guess as to whether that will work or not, so if you want to be confident that your problem is fixed you should still get a backtrace. But this seems likely enough.

Actually I’m pretty sure you’re right. I’ve created backport requests and proposed runtime updates.

Awesome, the latest update fixed all the remaining issues! Thanks a lot for your help

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.