Can’t add ProtonMail account

I installed the protonmail-bridge, and now I’m trying to add the IMAP/SMTP corresponding account.
I’m using Fedora Silverblue 38, with Gnome 44.2 and Geary 43.0 from flathub.

I can’t succeed when using the « Online Accounts » creation within the settings. I’m getting the error in the screenshot below:

I can’t succeed when trying to create the account directly in Geary, then I get stuck on the screen show below

Any pointer on how to solve this issue ?

Tried downgrading to Geary 43.0, without success for adding the account within the application.

But by downgrading Geary further to version 40.0, the dialog to add an account actually let me configure the IMAP and SMTP servers, and I can successfully add the account. And on upgrade to the latest Geary version the account is still present.

However, it should still be possible to add said account using only the latest Geary version.

No idea how to setup geary, but protonmail bridge only supports STARTTLS (the error says that it does not support PLAIN which is one of the alternatives) with TLSv1.2 (any maybe newer) so you have to configure it. If you need the certificate for the connection it should be at ~/.config/protonmail/bridge/cert.pem or something like that.

You can choose whether to use STARTTLS or TLS for the bridge, from the bridge settings :wink:

I tried adding the account with the two methods, and choosing the appropriate method on the two sides (bridge and client).

For the certificate, in Geary 42.0 I also added the certificate (exported from protonmail-bridge) to the trust anchor with

sudo trust anchor ~/Documents/protonmail-bridge.pem

That removed the following warning when trying to add the account with the settings program:


However, the message complaining about the PLAN method persist.

I haven’t been able to get it to work with Geary either. I did, however, have much better luck with Evolution.

I got it to work with Geary, but with a convoluted way.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.