Can build but not run applications with Builder (xdg-document-portal isn't working?)


I am on Fedora 31, and am trying to build and run applications using Builder. Applications build fine, but I keep getting this error when I run the application (for example with gnome-music)

bwrap: Can't find source path /run/user/1000/doc/by-app/org.gnome.Music.Devel: No such file or directory

On further investigation, I found this issue related to it:

I tried all the fixes suggested above, including

systemctl --user restart xdg-document-portal

But I still keep getting the same error. When I look at the running processes with ps aux, I cannot find xdg-document-portal, but I can find xdg-desktop-portal.

My system is up to date, and I have tried using nightly Builder as well as stable. Builder was installed from flathub with the command

flatpak install --user org.gnome.Builder//master

On running builder from command line with flatpak run org.gnome.Builder, I find the following error

F: Can't get document portal: GDBus.Error:org.freedesktop.portal.Error.Failed: Can't mount fuse fs

In the issue above, it is suggested to do

fusermount -uz /run/user/1000/doc

This command gives me the error

fusermount: entry for /run/user/1000/doc not found in /etc/mtab

I cannot wrap my head around what is going on. Please help me fix this.

Thanks in advance! :smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.