Bug with gtk4 menus only with flatpak?


I noticed this strange behavior few monthes ago using gnome-text-editor and thought it was a problem for that software only (still in beta). But I have the same problem for a toy learning project that I’m developping using gnome-builder.

Steps to reproduce:

  1. Open gnome-text-editor (from flathub)
  2. Click on the hamburger button in the headerbar. The menu opens.
  3. Click on the hamburger button again to close it (without choosing anything in the menu). It doesn’t close.
  4. The menu only closes when pressing the escape key (or obviously if you click something in the menu).

With a non-flatpak version of gnome-text-editor (same version), clicking the hamburger button the second time closes the menu.

And I have the same behaviour with my own program.

Am I the only one? Should I file a bug towards gtk4? Or towards flatpak? Or toward XWayland (I’m using X11)? Or some other component?


I can’t reproduce with GNOME Text Editor’s nightly build—using GTK 4.6 and libadwaita 1.0.

I’d recommend you try with the nightly build and see if that works. If you can reproduce, then feel free to open an issue against GTK.

Thank you. I Can’t reproduce with nightly build of gnome-text-editor. Will try to use this runtime for my own program, but I guess it will be solved too.

Hmm. Not solved for me. I’ll have to dig in the code.

It’s based on the example in gtkmm4 book (link. Obviously not using libadwaita. I will try to update it to libadwaita.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.