Black/White Icons in recent Evolution 3.46

Hi everyone,

first of all, I hope I tagged and categorized this post correctly.

I am currently running Evolution 3.46.2-1 on my Debian Testing system. After one of the recent updates, my evolution style seems to have changed and now features mostly black/white icons. It looks like this:

2023-01-05-121338_413x455_scrot

The folders, for example, used to be blue before. Some icons still have some color (e.g., the “new mail” icon still has the “blue dot”). Is this change intended or is something not working properly for me? I tried finding the icons for “Inbox” and found through strace that evolution uses

/usr/share/evolution/icons/hicolor/scalable/actions/mail-inbox-symbolic.svg

Is this the right image? It seems that all symbolicimages are only black and white. I’m a bit clueless as to where I should look to get back the colors. My first attempt was to check if a .css file is missing that styles the .svg, but I found that only one single .css file was opened (~/.config/gtk-3.0/gtk.css). It didn’t exist at first, but after symlinking it to /usr/share/themes/Adwaita/gtk-3.0/gtk.css it was opened but no changes are visible.

Please note that I’m running with hidpi settings, so the fonts in the screenshot are larger than the icons (but this is unrelated to my icon issue discussed here).

Any help is appreciated!

Best regards
Christian

Hi,
the Adwaita icon theme switched to symbolic icons (it’s the Adwaita
icon theme developer’s decision). When Evolution detects the icon theme
uses symbolic icons, it also uses symbolic icons, to have the view
consistent. When you change your system icon theme to a colored one,
the Evolution should use colored icons too.

Note there is no API to know whether icons are symbolic or not, thus
the detection on what the icon theme uses is a heuristic, not an
explicit API call (aka the heuristic can fail).

Bye,
Milan

Thank you for your answer, Milan. As I understand it, this not the result of something that I’ve done wrong, but using the standard Adwaita theme will result in black/white icons due to the Adwaita mainainer’s change.

Does this mean that this is now the out-of-the-box gnome/evolution look?

You said that Evolution has a heuristic that detects which icons to use. How can I influence/overwrite this heuristic or do I have to change the theme on a system-wide level? I tried to set the icon-theme to a different theme (I just installed “Papirus”) but checking the strace output yields that still the Adwaita icons are loaded (probably since only the icon-theme was changed whereas the gtk-theme style is still set to Adwaita).

Thanks for your help!

Best
Christian

Hi,
correct, you did not do anything wrong, this is what the Adwaita icon
theme folks want it to be.

If you use GNOME desktop, then install gnome-tweaks and change the icon
theme there. Other desktop environments have their own place where the
icon theme can be changed. Just installing the theme is not enough to
have it used.
Bye,
Milan

Hi Milan,

thanks a lot for your help. I have Gnome installed (and it is active) but my WM is Xmonad. Setting the icon theme didn’t change anything (I checked through gsettings get org.gnome.desktop.interface icon-theme that it was correctly set.), which I find surprising since Evolution does get the configuration value for “gtk-icon-theme-name”…

Anyways, I found a (hacky) solution which I will document here just in case someone else also wants to change back to the colored icons: the heuristic you pointed me to in an earlier post is located in src/shell/main.c (function e_setup_theme_icons_theme_changed_cb) and checks if there are 16x16 icons in the actions folder that start with appointment-new, edit-cut or edit-copy and whether there is at least one that does not contain the substrings -symbolic. or .symbolic.. If there is at least one, Evolution does not use symbolic icons.

Hence, linking one of these icons was the solution. For me (Debian Bookworm), the solution was:

ln /usr/share/icons/Adwaita/16x16/actions/edit-cut-symbolic.symbolic.png /usr/share/icons/Adwaita/16x16/actions/edit-cut.png

Looks much better now.

Thank you so much for your help!

Best regards
Christian

Hi,
the above makes sense, the GSettings you found belongs to the GNOME,
not to the Xmonad. There should be a similar setting somewhere, owned
by the Xmonad itself. I do not know that window manager, it may or may
not have its own Appearance setting somewhere in the GUI. Finding and
using that would be clearer solution than creating a link on the file
system level. Just saying, I’m happy you managed to make it work the
way you like it.

Bye,
Milan