Asking for help: Can't reenable VM's keyboard shortcuts after declining once

Disclosure: This is a cross-post from Ask Ubuntu, which hasn’t received responses so far.

I’m running Ubuntu 23.04 and I have recently installed Fedora 38 as a VM in GNOME boxes.

When I added the VM for the fist time some days ago, I remember a window popping up asking if I’d allow the VM to change keyboard shortcuts, which I declined by mistake.

Now, naturally, Fedora’s shortcuts won’t work; all shortcuts are still assigend to the parent OS Ubuntu. (For instance, when I hit the super key, Ubuntu’s app drawer will open, not Fedora’s.) I reinstalled (and purged) gnome-boxes and its dependencies, but when I add Fedora as a VM now, the above-mentioned prompt regarding shortcuts never reappears and shortcuts won’t work as a result.

Can anyone point out how one can (re-)enable a VM’s keyboard shortcuts as a whole in boxes? It’d be much appreciated.

Open Settings and navigate to Apps → Boxes. There should be an “Inhibit Shortcuts” switch:


Thank you! Who would have thought that settings could be altered in, well… Settings. :man_facepalming:

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.