Activities button in Gnome 43 as in 3.38


I’m using Debian 11 and thus Gnome 3.38. In about 3 weeks I’ll update to Debian 12 and Gnome 43. I like many thins about Gnome and since I’m left handed I really enjoy the way the “Activities” button works in Gnome 3.38, that is the same effect as hitting the windows key.
I’ve had a vm with Gnome 43 for months and I’ve never been able to set up this “activities” button correctly whereas it took me a few seconds to do this with Cinnamon.
Can someone please let me know how to set Gnome 43 the way I need?

What does clicking the activities button do for you on Gnome 43 and how is it different from pressing the Windows key?

I’m on Gnome 44 but was until recently on Gnome 43. Clicking the activities button does the same thing as pressing the Windows key: it toggles the activities overview (primary is it shows your open windows on the current workspace). I tried Debian 11 on DistroSea but clicking the activites button there does the same thing for me.

On Gnome 43 I have to click this button, on 3.38 i don’t have to click, I just have to place the pointer in the top-left corner. It is much more convenient.

Ah. I think that’s because you’re using a VM. I have that issue with VirtualBox in full screen. I usually run VMs windowed so rarely notice. The “fling mouse cursor to the top left” way to open the activities overview works fine on a real hardware.

Will your Debian 12 install in 3 weeks be in a VM or on real hardware?

Hopefully you’re right. Debian 12 will be on real hardware. I find it strange not to have a setting for this though.

Don’t worry, the hot corner works fine on Gnome 43 on real hardware.

If you search for it you can find other users having the same issue on VMs, not just with Gnome 43. This happens when the VM is configured to not capture the host pointer (probably the default). Then the VM only gets mouse events that happen inside its window. The “fling pointer beyond top left corner” happens outside it so doesn’t trigger the hot corner.

So one possible workaround is to configure the VM to capture the pointer. While the VM is running the host won’t have access to the mouse and all mouse events go to the VM. Then the hot corner works.

Thanks a lot for your explanation. I’ll give it a try with the Debian 12 VM, then I’ll update my computer to Debian 12 as well.

If you want to use hot corners inside VirtualBox VM, just disable mouse integration option, so the mouse pointer can apply “pressure” on the corner inside the VM instead of continuing out of the VM’s window (even if it’s full-screen).

1 Like

I’m using KVM, not VirtualBox.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.