A critical issue with On screen keyboard that makes it impossible to use for non-English speaking cultures

These days, I’ve had many issues with most Linux distributions and DEs regarding globalization.’
I’ve written a detailed “rant” here.
The issue I discuss here is related to globalization but not included in the rant above.

Basically, Gnome’s built-in on-screen keyboard will not change its layout when using non-Latin languages(Korean tested here)(used Ibus).
A video demonstration of the issue can be seen here.

Despite changing the input language(using the globe icon button) to ibus-hangul(which types Hangul) or Korean(which types English and not Korean for some reason), the on-screen keyboard remains in English.

This is what the default QT on-screen keyboard can look like when using Korean.

I have not tried other languages to see if this issue persists.

Is this a bug? Is this an issue nobody else noticed? Or is there some toggle or tweak I have to do to get Korean language layout on my on-screen keyboard?

Thanks.

I’ve asked around and the maintainer says “eek, that broke.” Sounds like you’re the first person to notice and report it, or at least the first report that we noticed.

Please create an issue report here. You can attach the label “5. On-screen Keyboard” to the report. Thanks!

Thanks! I just wanted to make sure this was a bug and not just a settings thing. WIll make an issue rn!