15 years AMD laptop on gnome 42 no wayland session

I have a Dell laptop that I bought in 15 years. When I installed gnome42 today, I found that I can only log in to the session option and there is no wayland. I can only enter x11. My laptop cpu is A10 7300, the core display is R6, and the independent display is R7 M265, lspci shows that the driver used for my nuclear display is radeon, while the independent display is amdgpu. I am using an open source driver. Is it no longer supported to enter a wayland session on this type of machine?

1 Like

15 years old GPUs are hard to support.

It’s extremely unlikely that GNOME is at all involved; I assume that, in order to install GNOME 42, you had to perform an OS upgrade.

GNOME requires specific EGL extensions to be available when using Wayland; if you upgraded your version of Mesa you might have dropped some legacy driver. I recommend asking on a user support forum for your Linux distribution.

1 Like

Hi! I have the same problem with a desktop PC with AMD A10-7700K.

After being reminded by users in the archlinuxcn community, gnome no longer supports the redaon-driven core graphics card after 42. When I disabled it and used amdgpu to drive the core graphics card, I could log in in wayland, but the performance was not good.

1 Like

You can log in with amdgpu instead of radeon

1 Like

GNOME isn’t really responsible for the drivers provided by Mesa: we just use them.

Mesa recently got through a removal of old, unmaintained drivers like the r100/r200 radeon which may have affected your system.

2 Likes

Hi. I think the drivers i am working with are the radeon drivers if i am not mistaken. How can i use the amdgpu driver? thanks.

Graphics:
  Device-1: AMD Kaveri [Radeon R7 Graphics] driver: radeon v: kernel
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: radeon
    unloaded: fbdev,modesetting,vesa gpu: radeon resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD KAVERI (LLVM 13.0.1 DRM 2.50 5.17.1-arch1-1)
    v: 4.5 Mesa 22.0.1

You would probably get better answers in some other forum, but my guess is your graphics card is just too old to use the amdgpu driver. If it’s compatible, then it should just work without need to configure anything.

2 Likes

I don’t know what distribution you are using, but please refer to amdgpu in archwiki, where si_support and cik_support seem to be enabled for amdgpu, then blacklist disable radron, specify the driver in the X11 file, and finally regenerate the /boot directory file,use mkinitcpio -P or drauct /boot/init …

2 Likes

Hi. It’s a pity that a 7 years old graphic card is already considered old for Linux. I will continue with Xorg because for now it works fine.

This is my card in ArchLinux:

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics]
	Subsystem: ASRock Incorporation Device 1313
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu


1 Like

Solved by enabling the amdgpu driver in the grub. Thank you very much

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics]
	Subsystem: ASRock Incorporation Device 1313
	Kernel driver in use: amdgpu
	Kernel modules: radeon, amdgpu

1 Like

I had same problem. I shall be very thank full to you

1 Like

Interesting thread. I fell into this trap when I upgraded to the release Gnome 42. It would have been nice to be warned because all through the beta of 42, mine worked just fine with (Debian SID) it’s a: Curacao PRO [Radeon R7 370 / R9 270/370 OEM] which I guess is older than I thought, but still capable. The beta of Gnome 42 wasn’t sluggish at all using this card. I have enabled the amgpu driver and will now test upgrading to testing from Bullseye, now that I know the issue.