Web epiphany Raspberry Pi script to open web page at startup in same Tab

I have a problem !
I have a script that opens Web epiphany each weekday when my Raspberry Pi starts-up and it displays a webpage. But each day, it opens a new Tab.
Is there a way to tell the script to open the webpage in the first tab. So that I have only one tab.
Thanks for the help.

I think you could either (a) disable session restore (Preferences → Session → Restore Tabs on Startup), or (b) close the browser with Ctrl+W (not Ctrl+Q) when you have only one tab open, in order to delete the tab from your session state rather than save it.

Thanks for your suggestions.

It is real strange. But the option disable session restore, was not selected. So it was not supposed to restore the session. In the French version the phrase is written in a way that if the option is not selected it will not restore the sessions. Would it be wrongly translated ?

I close and shut down the raspberry pi with a script.
Is there a way to close all tabs before quitting the App ?


No, that’s right.

Is there a way to close all tabs before quitting the App ?

Not from a script.

If you’re using Epiphany as a kiosk, maybe something like Cog would be a better choice for that purpose?

Hmm, deselecting that option works for me. What version of Epiphany are you using? I think some very old versions might incorrectly open the new tab page in addition to the page that you are trying to open. Is that what is happening?

Raspbian pinned Epiphany at 3.8 for some unclear reason across several releases, no idea if that’s still the case

Ok so I went to see what version of Web is installed. It is : version with WebKitGTK+ 2.30.3

My shell script is just basic : epiphany-browser url
With the url of the page I need to open.
Would there be some argument to tell it to open the url in the first tab ?

I think you just need to upgrade to newer software versions. Especially if you’re connecting to the internet: you really don’t want to use old versions of WebKitGTK on the web.

Pretty sure your issue is fixed in current versions.

For the moment I cannot upgrade. The version of Raspberry Pi I have installed is a dead version in terms of upgrades.
What is the actual version of Epiphany-browser ?

See: https://gitlab.gnome.org/GNOME/epiphany/-/tags

But note that WebKitGTK version is also security-critical. I’ll never understand why people connect ancient browser versions to the web…

Well, it’s not really my case. Because this device connects to an Internal webserver. It’s for a TV that displays the class-room occupations. It’s not really in danger. But it could be vulnerable. So I will try to get it up-to-date.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.