Trouble compiling 32-bit build of gdk-pixbuf

What I think is going on is is the link stage is failing. Ninja is invoking gcc, which in turns tells the
linker to link 64-bit binaries. The /usr/lib32 folder is sound with 32-bit libraries in place. I went
and looked at build32/gdk-pixbuf/ which houses my temporary *.o intermediate object files. They
are compiled as 32-bit. So, the linking should work…

My meson invocation line.

The contents of my cross definitions file

The error goes:

But, the files in /usr/lib32 are not in the wrong format. Also, that gcc invocation quoted above will link, if I
add -m32 to it, like this: gcc -m32 -o gdk-pixbuf/pixops/timescale and invoke manually
Ninja just deleted timescale and tried again.
One other thing that I have tried is to add ‘-m elf_i386’ to the c_link_args properties in the cross_file.txt, or
adjusting the LDFLAGS with that addition prior to running meson.

I can’t figure this out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.