There may be a bug with the display in the zsh wayland terminal

Hello everyone, maybe this is a bug.
I use Fedora 36 (Wayland) and the zsh terminal (gnome-terminal 3.44.1)

When the window is resized, the pseudo-graphics creeps. The screenshot shows how it looks.

Playback method:

  1. Install zsh
  2. Open the zsh terminal
  3. Change the window size several times

Thank you in advance for your attention!

Similar looks to happen with bash: when I have a longer prompt and I resize the window to cause the prompt to line wrap, and I do that a couple of times, it starts looking like your screenshot. It doesn’t happen with dash. A difference between the two is that bash uses readline for line editing and dash doesn’t. If I run bash without using readline (bash --noediting) the issue does not happen.

I’m not familiar with zsh but I found it uses zle for line editing. I suggest disabling zle to see if you can still reproduce the issue then, just to point in a common direction why this happens with both zsh and bash.

I also note that this issue happens in other VTE based terminals such as the new Console app. I suspect the issue is between zsh/bash’s fancy line editors and VTE.

I tried it, there are no problems everything works fine.

I additionally checked the operation of the zsh terminal in the X11 session, and there is also such a problem there. So it looks like you’re right.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.