Super+1 Always Launches Firefox

I use super+(num) to jump to any workspace, so I changed the shortcuts as such in the tweak tool. All of the other numbers work fine, but when I press Super+1 it always launches firefox instead of navigating to the first workspace. I checked through all of the shortcut menus and there isn’t one to launch firefox (it isn’t even my default browser.) I even tried uninstalling firefox, and now it just says it is trying to load firefox in the panel but doesn’t do anything.

What you are seeing are shortcuts to launch the n-th favorite app in the dash (like in Ubuntu’s Unity).

They aren’t exposed in Settings, but you can disable them in a terminal:

for i in $(seq 1 9)
do
  gsettings set org.gnome.shell.keybindings switch-to-application-$i '[]'
done
4 Likes

Thank you! That fixed the problem for me.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.