Should libhandy be called libhandy?

Hi, I know that this is maybe nitpicky, but I feel this might be an interesting point: Should libhandy be called libhandy?

Why do I ask this?

I have read some posts about libhandy on the forum, especially Gtk4 and libhandy usage and also related on the Solus discourse and in those threads there is some information that is conflicting between Solus team and Gnome team regarding libhandy. For Solus team libhandy is a “mobile-first” library and for gnome team it’s gnome responsive widgets. The issue is, that one of the solus developer’s argument is him quoting the libhandy readme: “The aim of the Handy library is to help with developing UI for mobile devices using GTK/GNOME.” Which according to @christopherdavis is not true, it’s actually a widget framework for gnome-specific widgets. (with the added bonus that they are responsive and thus suitable for mobile as well)

What’s my point?

If a name of a library is misrepresenting the actuall function of the library, then the name is bad. “handy” is german for mobile phone, maybe it is only my knowledge of a certain language, but even in english it doesn’t make much indication to what the library does, it is “handy=useful” library, what does it do? I have provided one example and although it is very subjective, I believe that Solus developers aren’t the only ones mislead by the name and the project description and aren’t the last.

What do I suggest?

Changing the name, of course! I have one suggestion and that would be libgnomewidgets as it clearly indicates that these are widgets specific to gnome and is no “mobile-first” library (also adding naming the widgets instead of Hdy... to Gnome..., for example: GnomeHeaderBar)

What if renaming isn’t easy or maybe impossible?

If that is a case, it’s up for debate and for the Gnome team to decide, I merely want to create a discussion about this, this might very well be insignifficant to some, but I feel this can at least be thought about. I welcome any opinion, as I merely want Gnome to be even more awesome than it is today (which is going to be hard)

We do have a plan to rename it to libadwaita for GTK4, with Adw namespace. :slight_smile:

Unfortunately, libgnome$ANYTHING is out of question because libgnome and libgnomeui actually existed before. See


Yes, that’s great! But isn’t adwaita a theme more than a toolkit/library? Or is adwaita going to become something more than just a theme?

1 Like

It’s the name of the design language. The fact that its gtk stylesheet is technically a theme is an implementation detail really, just like the elementary stylesheet is. :slight_smile:


Okay. I understand now. Thanks for the clarification! It may confuse some users that use themes, but that’s not really problem since this library is for developers only. I’m really glad that there are plans to change the name, it isn’t terrible but it was not an ideal name for this kind of library. New name makes much more sense and it’s a good name. :slightly_smiling_face:

It probably will be if the implication is that it only supports one theme…

Libhandy never supported anything else than Adwaita…

Right, understandable but very unfortunate.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.