On-screen keyboard is broken on Xorg GNOME 40.3

Hi everyone!

I’ve tried both Fedora 34 and Manjaro on my Thinkpad 10 Tablet (sort of 2-in-1 device) and since the update of GNOME 40.3 the OSK under a Xorg session doesn’t work properly. I’m pretty sure it worked on GNOME 40 or 40.1.

The issue is that the virtual keyboard doesn’t register the keypress but instead the touch is registered on whatever window that is behind.

The issue is not present in Wayland sessions. This kinda breaks the OS experience for me, I’m using wayland for now but that have other problems and is not ready yet for daily usage on my device.

Can someone help? Thanks.

If something seems like a bug the best place to report it is in the project’s issue tracker on gitlab. This specific bug was something I also noticed a while ago and now had the time to look into it. I filed this issue with some additional details: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4556

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.