Missing tab / screen on web application using GTK and Broadway

Hello All

I have developed a simulation program that I would like to deploy as a web application. The program simulates chemical reactions and is written in C++ on Debian Buster, using the GTKMM3 wrapper API for GTK. The GDK Broadway backend provides support for displaying GTK+ applications in a web browser, using HTML5 and web sockets.

I have tried it and it worked almost straight away! But there is a problem. The user interface for my simulator uses a Gtk::Notebook widget with 5 tabs. I can start the simulator and it runs fine. The user interface is pretty snappy, although currently my ‘server’ and ‘client’ PCs are both on a local network. The problem is that one of the tabs has almost nothing on it. It is supposed to show the state of the simulation, including lists of molecule types and ‘stick’ diagrams of molecules.

I am not getting any error message or anything that could indicate what the problem may be. Any ideas on how to approach this problem or where to look would be much appreciated.

Chris Gordon-Smith

Hi! :slight_smile:

The problem is that one of the tabs has almost nothing on it.

What do you mean exactly by this? Do you have screenshots of what you see with Broadway and what you expected to see instead (which is shown correctly on your normal setup, e.g. running natively on Linux/Windows)?

You might want to try running with G_DEBUG=all but if there was any error or warning they should already have been shown in the logs.

Thanks for the response. I have taken two snapshots. The top one is what I get when running native / normally. The second is what I get with Broadway.

I’ve tried G_DEBUG=all, but I get no debug output.

Any further thoughts appreciated.

Here is the second screenshot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.