Meld and X11 Forwarding using ssh

I have a strange problem that I’m not seeing with other apps. Not sure if it’s GTK+ specific or something related to X11.

I have two linux machines: server and client both running Ubuntu (one is 16.04 the other is 20.04).

If I ssh from client to server with X11Forward enabled, I can run meld and see it on the client. (The only strange thing is that the meld window is now missing the “Meld” menu entry???) However, any subsequent instances of meld that I initiate back on the server will also open on the client. Once I close the client meld, new server melds will once again open on the server (and also have the “Meld” menu entry.)

The opposite also holds true. If (while the same ssh session is active) I run meld on the server, it opens on the server, but any melds I run from the client via ssh will now also open on the server instead of the client.

Any thoughts?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.