Make italics work in Discourse's "Deneb" theme?

Is there any reason that italics don’t actually show up in Discourse posts, or in the preview? For example, every time I write the word “bold” or “italics” in this post, I’ve formatted it accordingly. And yet…

You can add the necessary MarkDown all you like — either directly by surrounding text with single underscores / asterisks, or by using the editing toolbar to apply the same — but the formatted output appears completely resistant to any sort of slanty-letter tomfoolery.

Even weirder, if you try to combine bold and italics together, like I have on these words here, it loses the bold formatting as well.

(If italics are intentionally disabled or something, it’d be nice if the option could be removed from the edit toolbar, instead of applying and silently discarding the MarkDown styling.)

Looks OK to me:

Huh, interesting. And I now see that the HTML markup is, indeed, embedded in the (rendered) source of the posts.

The difference seems to be the theme. When I posted this, I was using the “Deneb” theme. (Not sure if I selected that, or if it was the default, or what.) I just experimentally switched my account into the “Light” theme, and bam — suddenly, italics!

Switch back to “Deneb” theme, and my own post looks like this again:

Hrm. It does look like an issue with the theme, and our fonts we pull in. I can’t actually see what the underlying problem is - the fonts seem to be downloaded and the text is styled properly.

I’ll ask around and see if anyone has any ideas…

1 Like


Yeah, it’s really strange. I have the WhatTheFont? (er, I mean WhatFont — WhatTheFont! is the web tool) browser extension installed, and at one point I was staring at this popup swearing to me that I’m looking at 15pt Source Sans Pro italic, and I’m thinking, “BUT IT’S NOT!!”

Makes no sense. I know Source Sans Pro comes in italics, I have it installed locally and it’s my default browser font. It displays italics just fine:


But Discourse’s web-font version (I presume?) seems to be b0rked somehow.

I am using the Deneb theme, and I can see the italics:

So I’m not entirely sure this is, strictly speaking, a theme issue per se, but maybe an interaction between webfonts and your font configuration.

For info, on my machine, it works in Epiphany and Firefox, but not Chrome. I suspect this may be a chrome bug.

Edit: I’ve fixed this now. Linking to an external css file on was causing the issue. I changed:
<link href="" rel="stylesheet">
<link href="" rel="stylesheet">

I’m not sure why dropping the protocol works, but it did. You can now have italics, bold and bold italics to your heart’s desire!

1 Like

Sweet! Confirmed, my original post shows up in all its ransom-note glory now. Many thanks.

Hmm, doesn’t Discourse have some sort of “Mark solved” type functionality? Is that only enabled per-category? “Site Feedback” seems like one that could make use of it.

1 Like

It’s enabled per category, and also enabled on #site-feedback too now :slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.