Libwayland-client missing for Ubuntu 20.10

When installing gtk4 on Ubuntu 20.10, the meson _build . instruction fails with the error below.
I have installed all wayland-client packages I could find: libwayland-client-extra++0, libwayland-bin, libwayland-client++0
Does anybody have a clue what I am missing?

Dependency gtk-doc from subproject subprojects/gtk-doc found: YES 1.33.2
Dependency tracker-sparql-3.0 skipped: feature tracker disabled
Dependency colord skipped: feature colord disabled
Dependency cairo-xlib found: YES 1.16.0 (cached)
Dependency cairo found: YES 1.16.0 (cached)
Run-time dependency cairo-script-interpreter found: NO (tried pkgconfig and cmake)
Library cairo-script-interpreter found: YES
Run-time dependency wayland-client found: NO (tried pkgconfig)

meson.build:462:2: ERROR: Dependency "wayland-client" not found, tried pkgconfig

Most likely libwayland-dev

Thank you for the fast response, it worked and I figured out a few more steps.

I am trying to build gtk 4 using the readme:
$ meson _build .
$ cd _build
$ ninja
Currently I’ve got a couple of fails on the ninja step. I’m sure I’ll get there, but there are a lot of moving parts…

[219/2579] Generating gdk-pixbuf-marshal_h with a custom command
INFO: Reading ../subprojects/gdk-pixbuf/gdk-pixbuf/gdk-pixbuf-marshal.list...
[435/2579] Compiling C object subprojects/libepoxy/src/libepoxy.so.0.0.0.p/meson-generated_.._egl_generated_dispatch.c.o
FAILED: subprojects/libepoxy/src/libepoxy.so.0.0.0.p/meson-generated_.._egl_generated_dispatch.c.o 
cc -Isubprojects/libepoxy/src/libepoxy.so.0.0.0.p -Isubprojects/libepoxy/src -I../subprojects/libepoxy/src -Isubprojects/libepoxy/include -I../subprojects/libepoxy/include -Isubprojects/libepoxy/include/epoxy -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -std=gnu99 -O2 -g -fPIC -Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -Wunused -Wuninitialized -Wshadow -Wmissing-noreturn -Wmissing-format-attribute -Wredundant-decls -Wlogical-op -Werror=implicit -Werror=nonnull -Werror=init-self -Werror=main -Werror=missing-braces -Werror=sequence-point -Werror=return-type -Werror=trigraphs -Werror=array-bounds -Werror=write-strings -Werror=address -Werror=int-to-pointer-cast -Werror=pointer-to-int-cast -fno-strict-aliasing -Wno-int-conversion -fvisibility=hidden -MD -MQ subprojects/libepoxy/src/libepoxy.so.0.0.0.p/meson-generated_.._egl_generated_dispatch.c.o -MF subprojects/libepoxy/src/libepoxy.so.0.0.0.p/meson-generated_.._egl_generated_dispatch.c.o.d -o subprojects/libepoxy/src/libepoxy.so.0.0.0.p/meson-generated_.._egl_generated_dispatch.c.o -c subprojects/libepoxy/src/egl_generated_dispatch.c
In file included from ../subprojects/libepoxy/include/epoxy/egl.h:46,
                 from ../subprojects/libepoxy/src/dispatch_common.h:59,
                 from subprojects/libepoxy/src/egl_generated_dispatch.c:11:
subprojects/libepoxy/include/epoxy/egl_generated.h:11:10: fatal error: EGL/eglplatform.h: No such file or directory
   11 | #include "EGL/eglplatform.h"
      |          ^~~~~~~~~~~~~~~~~~~
compilation terminated.

You want libegl-dev.

GTK cannot use Mesa as a sub-project, so you will need to install some system dependencies.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.