Is there any way I could fix or mitigate the blur on applications using XWayland caused by fractional scaling?

The other day I installed Fedora Workstation 38 and I’m running into a couple of problems. One of which is scaling/blurring. The default 100% scale was far too small for me to use and the 200% scale was far too large. I tried using the “large text” accessibility feature which worked well for GNOME and the default GNOME applications, but not for any other application. After searching around, pretty much every resource mentioned that you can enable fractional scaling on GNOME using:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

After restarting, I was able to select options for fractional scaling. I found 125% or 150% to be better. 125% is a bit too small and 150% is a bit too large, but I can live with it, so I chose to stick with 150%.

After scaling up to 150%, I noticed that some of my applications are now blurry. In my experience, it seems to me that this might only be happening with applications running on XWayland. One reason I believe this might be the case is because of my experience with Brave. By default, Brave uses X11. However, when I set the Preferred Ozone platform flag to “Auto” or “Wayland”, the application is no longer blurry. I still have other applications (such as Bitwarden, Standard Notes, and ElectronMail) which I assume to be running on XWayland and are still blurry. I haven’t yet installed all the applications that I’d like to use, but I’m thinking that most of them (including games) are going to be running on XWayland and are therefore going to be blurry.

Is there any way to fix or mitigate the blurriness of these applications? Or am I essentially stuck choosing between clear but tiny icons/text/etc and using blurry applications? (And on another note, is there any way I can check which applications are using XWayland vs. Wayland?)


After posting to GNOME Discourse, Fedora Discussion, r/linuxquestions, r/linux4noobs, r/gnome, and r/Fedora and waiting for about a week, I’ve only gotten one response under the post in r/Fedora. The one response I got wasn’t related to how I might be able to solve the issue or whether or not that’s possible to begin with, but instead, the user suggests that it’d be best to switch to KDE Plasma which supports fractional scaling. This seems to correspond with what other users ended up doing. For example, another user asked about the same issue on the Fedora Discussion forum and after receiving no response, they ultimately moved to KDE Plasma which seemed to work for them. However, it’s important to note that they were using X11 on Plasma rather than Wayland whereas I intend on sticking with Wayland. That being said, it looks like Plasma still has better support for fractional scaling on XWayland. As much as I loved GNOME, it just doesn’t work on some displays, as is the case with mine. That being said, it would’ve been nice if I could’ve at least gotten a response like “No, you can’t fix that on GNOME” rather than having to wait over a week with a barely functional laptop only to realize my only option is to switch to a different desktop environment.

Yes, the blurriness for X11 applications running with fractional scaling is expected, and it cannot really be fixed without porting those applications away from X11.

What KDE does is precisely what GNOME does when changing the text scaling factor; the only difference is that KDE modifies the Xrdb settings database, which is what applications using Qt or older X11 toolkits use, whereas GNOME changes a setting that is used by GTK applications. If you want GNOME to do the same as KDE, change the text scaling factor for GTK apps; for Qt/KDE/Motif applications, you’ll have to compute the desired DPI value and then write it inside the $HOME/.Xresources file, like:

Xft.dpi:   141

and restart your session.

Incidentally: this is a user support forum. You are not owed a reply, not even after a week. You could have also searched elsewhere, because this is a question that gets asked multiple times.

From what I’ve seen, Plasma also offers “Scaled by the system” and “Apply scaling themselves” modes, which looks like a decent “solution” that could (easily?) be used. I’m not sure if GNOME has anything similar to that.

I’m a little hazy on the step-by-step process for how I would do that, but if anyone has the time to walk me through it, I’d be happy to give it a try.

My comment at the end wasn’t directed entirely at the GNOME community. I understand this is a free community support forum and no one owes me their time. I was just expressing frustration with getting support for desktop Linux as a new user in general. It looks like there’s lots of fragmentation, so far fewer people will see your questions. Furthermore, to search for whether your question was already asked or not, you’d have to scour the internet by looking for every possible forum and chat room it could’ve been asked in, and then searching for various terms within each of those forums and chat rooms to see if anyone has answered your question in the past. It’s just unreasonably time-consuming.

I’ve searched on the GNOME Wiki, the Fedora Wiki & Docs, GNOME Discourse, Fedora Discussion, etc. Still, I couldn’t seem to find a clear answer to the question I had. I did see some posts that could be related to it, but after skimming through some of those threads I still couldn’t find an answer. As mentioned in my update, I did see someone who asked about the same problem with the same software I am using, but they never got an answer either. I then asked on several relevant and popular forums (as mentioned earlier) and didn’t get a response. At least until now, I suppose.

If the information for something isn’t available on an easy-to-find FAQ and people cannot find or receive answers when searching/asking on relevant and popular forums, then I don’t see how the blame lies on new users with limited time, energy, and technical knowledge for not being able to solve their problems with software that is (at least by much of the community) commonly praised for being noob-friendly.

If that’s the case, it’s even more surprising that it’s so time-consuming to find the answer to this question. Of course, I’m sure if someone had the time and energy, they could probably have pieced together the information they would’ve needed after searching for various terms on various forums and wikis and then investigating specifically what each article or answer meant if the solution wasn’t immediately clear. But that’s just not practical for most users who aren’t very knowledgeable or just want a functioning computer without having to do a whole lot of work to get it up and running.

Anyway, I appreciate your response. If anyone has the time, it’d be great if someone could walk me through how I might be able to mitigate the blur with XWayland on GNOME if that’s possible. If not, I could try out Plasma or maybe just switch to X11 like other users have, though I’d hate to have to do that.

Yes it’s time consuming but that’s the deal. Either you are spending your own time to figure it out or you are asking someone else to spend their spare time for you. Also please note that “noob-friendly” does not mean there will be no bugs or that everything will work as perfectly as every user expects all the time.

A setting for “Apply scaling themselves” will only work with applications that explicitly support that. Legacy X11 applications that don’t know how to scale will still have blurring or will have the wrong scale. Also I am not sure how much you may have searched for the word “XWayland” but I have seen many discussions about this, for example see this thread for a more in depth explanation of what is happening here: Full explanation of current HiDPI (fractional and integer) scaling support in Wayland

That’s fair. I’m not necessarily frustrated that people aren’t spending time on me specifically. I’m mainly just frustrated/disappointed that despite all the important and hard work that people have put into developing free software over all these years, it’s still not very accessible despite many claiming it is. For me, I’m just overwhelmed with all of the fragmentation as it results in plenty of additional work that could’ve probably been avoided if things worked out differently in the Linux world.

I may be wrong, but as far as I can tell, this isn’t really a bug. It’s just a feature that is poorly supported and it’s sort of hard to find information on how to get it to work better or what options you have at your disposal.

I did come across that post in my search. Admittedly, I didn’t read the entire post at first because I was just skimming through a bunch of threads and articles trying to find a solution and that thread seemed to be more about learning how things worked rather than someone asking a simple question about an issue and getting a simple answer with a solution. Since you brought it up, I can give it a read later when I have more time and hopefully it’ll help me figure out where I should go from here.

Thanks for taking the time. :smile:

Open source will always be fragmented because the whole point of it is anyone can change anything, so there is no way to ensure everyone uses the same thing. If that is a problem, I would suggest using something else. Sadly there is no “one size fits all”.

So I couldn’t seem to find any solutions.
It looks like the answer after all really just is:

I’ll be trying out different distros and DE’s, maybe even trying X11. If nothing works out, I may just switch back to Windows and hope I can switch to Linux in the future whenever I get a new PC that is more compatible with free software. I might give a future update on what I ended up using.

In my opinion, it is unlikely anyone will find a perfect solution because some old clients just don’t know how to scale. You can see the same thing on Windows when trying to run some older Windows programs on a high DPI display…

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.