Improve OSK usage or disable it totaly

Hello All, I need some help for “On Screen Keyboard” usage. In my CentOS environment with gnome GUI with “Touch Screen”, I have a problem with OSK comportment.

Description : When I touch a defined text aray on my touch screen, immediatly OSK appears on lower part of screen. This is not usefull for my usage.

Perimeter : Cash till solution world wide deployment for retail consumer

Question :

  • Is it possible to disable totaly OSK in configuration with Touch Screen. I have tried “Block Caribou” extention without result.
  • Is it possible to modify comportment like, OSK appear only when I finger swipe up on touchscreen ? As OSK on demand only.

OS Environment :

  • CentOS 7.7
  • gnome-shell 3.28.3

Hardware environment :

  • Nixdorf Wincor Cash Till
  • Touch Screen
  • USB keyboard

I’ve just tried the Block Caribou extension, and it works fine for me. Do you have a reproducible test case where it fails?

https://gitlab.gnome.org/GNOME/gnome-shell/issues/872 has more details

1 Like

Hello ,
Just one question, what is your gnome-shell version ?

During my test, I have disabled OSK with Block caribou but when I touch screen in text area, virtual keyboard popup.

To clarify: the issue here is that the OSK is popping up when there is a physical keyboard attached?

Hey guys,
I confirm, Physical keyboard is always attached to my Cash Till and OSK popping up.