How to stop GNOME messing with the keyboard layout?

I have a custom keyboard layout setup which works very well outside of GNOME or in Unity (which uses a fork of an old gnome-settings-daemon).

Without much details, the layout has three language groups, one Latin-based and two Cyrillic-based, which are all defined at once in xkb format; switching between them is mostly done using Super (mapped to the first group) and Shift-Super (mapped to the last group).

In the past, I was able to tell GSD to not touch the settings by doing:

gsettings set org.gnome.settings-daemon.plugins.keyboard active false

but in the newer versions this no longer works because settings have been restructured. I tried disabling the keyboard plugin completely (by editing .desktop which didn’t work, killing the process or renaming the binary — which did), but something still prevents my setup from working.

As long as I run GNOME, I’m stuck with the Latin (first) group, none of the group-changing hotkeys work. I also have changed org.gnome.desktop.input-sources.xkb-options to [], but that didn’t stop this from happening.

And this is not limited to GNOME — I observe the same behaviour in Budgie, which I understand also uses GSD.

I’ve been trying to fix this on an ‘on and off’ basis for a year now since Unity is aging and I run in compositing bugs more and more often, and I would like to switch to something else, but this issue is preventing me from even trying.

Please help :sob: