How to manage "background activity" notifications in GNOME?

In GNOME 3.34 I’ve noticed these new “background activity – XY is running in the background” notifications (maybe only with flatpaks?).

This feature is nowhere documented, so I have a few questions about it:

  1. When exactly is it shown? I guess on low available RAM?
  2. How can I manage it? In this case, I have an application where I chose “forbit [to run in the background]”, and now I want to change/revert that decision, because I guess GNOME now kills it in the background if I only minimize it. :thinking:
  3. Can I in general enable/disable that feature or so?

BTW in my German version of GNOME it is also not localized – a “bug”, I guess.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

This is the background portal, part of xdg-desktop-portal-gtk.

The intent of this notification is to inform the user when a flatpak application continues to run after all of its windows are closed. Unfortunately, the original implementation monitored open windows incorrectly and would consider an application running in the background if its windows were on another workspace. This should be fixed as of xdg-desktop-portal-gtk 1.5.2

In the future, there should be a setting for this in the Applications panel in gnome-control-center. For now, you can remove all background permissions with flatpak permission-remove background background or all permissions for a specific application with e.g. flatpak permission-reset org.gnome.gedit.

I don’t think so, but it shouldn’t be particularly bothersome when working properly.

The strings are marked as translatable, but the German language translation appears to be incomplete.