High CPU usage on Wayland

I recently switched to GNOME on Wayland for better support for multiple monitors with different refresh rates. GNOME on X.org works pretty poorly with my two displays, one 144Hz and the other 60Hz, the animations are not quite fluid enough for my taste.

However now, that I switched to Wayland, I’m noticing that gnome-shell seems to have really high CPU usage. It’s one of the few “heavyweight” processes I see at the top of System Monitor:
image

Sometimes the CPU usage goes up to 50%, which is quite annoying as the CPU heats up and its fans start to spin up audibly. I’m on a desktop so it wouldn’t be much of an issue, except that the DE isn’t a very demanding thing to run (or at least, shouldn’t be).

This didn’t seem to be an issue on X.org though, but I don’t want to use it as it tends to be quite buggy with my two monitors that have different refresh rates.

Any ideas on what could be causing, or how to further debug this?

For reference, here’s a list of extensions I’m using. Maybe one of these is the culprit:

  • PaperWM
  • User Themes
  • GTK Title Bar
  • MPRIS Indicator Button
  • NoAnnoyance
  • Launch new instance

PaperWM would be my first guess/look at, given its functionality. Could you check if the issue still exists with it, or all extensions, disabled?

It appears that the CPU usage is caused by tweening, as animations when switching between windows impact my CPU usage quite heavily. Of course if I disable PaperWM completely the issue stops, because then there are no window sliding animations at all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.