Hearing Loss Risk Gnome Sound Settings

There’s a health related problem with Gnome’s sound settings that needs to be corrected.
Volume can suddenly go up when using different applications for hearing videos or music. I’m always very careful when using headphones because I already have hearing problems. It happened to me and it was very painful and a couple of days after my ears still hurt.

I tried fixing this by manipulating the volume mixer but it really behaves in unexpected ways so it is not clear how should the user set the volume because sometimes sound is up for one application and down for another and the volume manager should prevent this from happening.

Anyway, have tried managing volume controls but there’s always seem to be a problem where it’s impossible to set the precise overall volume output and prevent sudden volume changes. If the volume manager is not clear for the user and it also behaves unexpectedly then it is definitely a software problem.

Programmers and designers should be very careful when developing applications that could hurt users and I think that there are no safety guidelines being followed or enough testing to prevent this from happening.

I know that sometimes software is provided “as is” but for some pieces of basic software there should definitely be a project’s a responsibility for users safety. At least in something very basic and widely used as volume controls.

I may have encountered the same bug once.
Do you have this line in your /etc/pulse/daemon.conf ?
; flat-volumes = no
If so, try changing it to:
flat-volumes = no

1 Like

Thank you very much @MatthewS Apparently this may fix it for now.

What I can tell is that flat-volumes makes all volumes controlled from the master output volume making all individual applications follow in the same scale.

Any ideas why this isn’t the default behavior? I remember using other versions of Gnome and tweaking this on the command line was not necessary.

This option should be the default behavior and there should be something like a “lock” that preserves changes from happening as to prevent hurting people’s hearing and unless the user explicitly wants to change this (and making sure he understands what he is doing with an explicit warning) then it could be changed just by modifying the configuration file on the command line. Although apparently having this controlled by a configuration file makes it possible that bugs may change this without the user noticing it.

I think the Gnome project should address this issue seriously and not discard is at an anomaly. I’m sure it has happened to more people but since it’s not that easy to submit a complain it doesn’t gets noticed.

Glad I could help.
IIRC this is not related to GNOME, this is sadly PulseAudio default behavior, which most (but not all) Linux distributions tweak.
For example, I am on Debian and it’s the default here.
This is an old and known issue, you can read more about it on ArchWiki
It really should be fixed by PulseAudio. If there is a default that most distributions change, then probably it is not a good default.

Thanks

I found this on the Archwiki you pointed to:

Note: The default behavior upstream can sometimes be confusing and some applications, unaware of this feature, can set their volume to 100% at startup, potentially blowing your speakers or your ears. This is why Arch defaults to the classic (ALSA) behavior by setting this to no.

I’ll report it on Pulse Gitlab: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues

I just looked up if there was already a discussion and it looks like default has been changed in PulseAudio a year and a half ago.
So maybe your distribution did not yet update the package or there is some bug where default ‘no’ is not used unless it’s specifically set it daemon.conf

I just tried to change the line back to ; flat-volumes = no and it still says flat-volumes = no when I run pulseaudio --dump-conf after restarting it via pulseaudio -k
I’ll see if the bug comes back after the reboot.

1 Like

Thanks @MatthewS

If this info is useful for somebody I’m using Debian 10.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.