GNOME shell suddenly only has two virtual desktops?

Apologies if this is the wrong place to ask.
Up until earlier today I could have an arbitrary amount of desktops in GNOME shell, now I seem to be stuck with two and can’t create more by just going further right.

Any idea where the setting for this lives (in the GUI and / or dconf) ?

I’m on Ubunutu 22.04 amd64, and things were working until the last reboot (due to the suspend / resume not being fully supported, I have to reboot with SysReq-REISUB, many times a day, so it’s possible something got corrupted).

I tried disabling all extensions and this still seems to be the case.

What is the output of gsettings get org.gnome.mutter dynamic-workspaces?

gsettings get org.gnome.mutter dynamic-workspaces

Weirdly though in dconf Editor I can’t see that setting

Using gsettings, I set it to false then true again, and now it is set to 4 static workspaces instead of two, which is a little better.

Why is the mutter gsettings schema missing in this screenshot? Does sudo glib-compile-schemas /usr/share/glib-2.0/schemas help?

Have you tried a “pure” GNOME session without extensions (including the ones that are preinstalled by Ubuntu)?

I’m asking because

$ gsettings get org.gnome.mutter dynamic-workspaces

is as expected, so maybe it’s an extension that interferes with the dynamic workspace handing.

Did you maybe install it as a flatpak or snap? dconf-editor will not detect schemas in the host’s /usr if that’s not available in the sandbox as /usr; at least for flatpak, that is not the case.

dconf-editor can still access the dconf database, but that only contains entries that have been changed, so without the schemas, it won’t show any settings that are at their default value.

I’ll check what I installed it with, it seems a weird thing to make available as snap or flatpak if that’s the result though :sweat_smile:

I rebooted and the same thing happened again, I was able to do the same thing with gsettings and end up with 4 desktops.

Have rebooted since and am back to two.

Just to clarify: That would explain why dconf-editor reports the schema as missing, not why dynamic workspaces stopped working for you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.