(gnome-shell-extensions): drive menu extension icon disappeared from Panel

drive menu extension icon disappeared from Panel

Excellent extension, wonderful work !

I am using Fedora Silverblue 34 / Gnome 40.0.0/ Wayland with some extensions including Dash to Panel Extension. Everything worked perfectly…until:

I tried to customize the extension.js file by changing a line so that the volume (or vendor/model) of the removable drive appears alongside the partition name [Feature Request ?]. But beginners (un)luck … it failed and the drive-menu icon has since disappeared.

Restoration of the slight change made to extension.js didn’t bring the extension icon back on the Panel. Neither following troubleshooting did work:

Removing default install folder ~/.local/share/gnome-shell/extensions/drive-menu@gnome-shell-extensions.gcampax.github.com
Deleting and reinstalling Drive-Menu Extension from extensions.gnome.org
Disable/Enable drive-menu extensions and/or all extensions with CLI or Gnome/Extensions App
Removing all extensions, thus leaving only a standard Fedora34/Gnome 40.0.0 system
Reloading session/rebooting system in-between those troubleshooting steps...

Did I miss deleting any others cache/config files ? How can I restore Gnome in it’s normal previous state so that I can re-install the extension again. Installing/Removing other extensions works perfectly by the way … Thanks for your help

No. Removing the extension (either via the app/cli tool or by deleting ~/.local/share/gnome-shell/extensions/drive-menu@gnome-shell-extensions.gcampax.github.com) and logging out should be enough.

Maybe it’s a bug in the website, and it gives you the latest extension version (for GNOME 41) instead of one that is compatible with GNOME 40?

Can you check the extension’s metainfo.json?

That’s my best guess, and apart from checking the journal for error message also the one one I got :slight_smile:

Thnaks for your reply !

Here is the metainfo.json file:

$ cat ~/.local/share/gnome-shell/extensions/drive-menu@gnome-shell-extensions.gcampax.github.com/metadata.json
“_generated”: “Generated by SweetTooth, do not edit”,
“description”: “A status menu for accessing and unmounting removable devices.”,
“extension-id”: “drive-menu”,
“gettext-domain”: “gnome-shell-extensions”,
“name”: “Removable Drive Menu”,
“settings-schema”: “org.gnome.shell.extensions.drive-menu”,
“shell-version”: [
“url”: “https://gitlab.gnome.org/GNOME/gnome-shell-extensions”,
“uuid”: “drive-menu@gnome-shell-extensions.gcampax.github.com”,
“version”: 47

And funny only the gnome-shell-extensions package extensions won’t show on the pannel: Place Menu, Application Menu and Drive-Menu tested so far. Other extensions like tofu menu or Recent Items display fine…

So that’s fine then.

Are there any relevant logs in the journal?

I am not quite familial in the journal : what sould I look for ?
The Gnome Logs Application shows no result for key word “extension”

And… Miracle… :innocent: the drive-menu application icon is back … and other gnome-shell-extensions package extensions alike: Place Menu, Application Menu , and so on…
So that’s settled…
Thank you for reactivity !

Maybe a Feature Request: the volume (or vendor/model/size) name of the removable drive could appears alongside the partition name in the pop up menu.
Especially Gnome mounting like /run/media/ might be more user friendly with something like
SanDisk 64Gb

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.