Gmail issues out of the blue

After no updates to the app or major configuration changes I am no longer able to connect to my GMAIL account. This is the exact debug output I am getting:

Thank you for the help!

Hi Andrew,

Timeout reached errors in Geary are typically caused by GNOME Online Accounts getting wedged and not responding to Geary’s requests. The easiest fix is to restart your computer.

The GOA bug is:

(Just repeating from the Matrix channel so that people can find the solution if they search here)

1 Like

Thanks, Michael!

Killing goa did not resolve the issue. Disabling ipv6 also didn’t help. Could this be a separate bug entirely?

Which GOA processes did you kill - there’s a couple. Did they re-spawn afterwards? Did a restart help anyway?

First I tried killing all of the names goa processes. They didn’t respond until I messed around with accounts in settings. Then I killed just goa-daemonand it did seem to respawn after re-opening Geary, but the problem was still bot fixed. I also tried restarting my machine several times.

And this morning it is working again… I will report back with any more issues. So weird.

You did not write your OS version… Did you happen to have problems also in browsing some websites?

A few weeks ago there was a bug in Fedora 34 prerelease (maybe also F33?) in systemd-resolver package, which caused weird network errors. I cannot find the bugzilla issue right now.

It was not related to the systemd resolver issue, no.

And this morning it is back again. I’m guessing a restart can fix it, just not always. Very annoying and I hope this is fixed ASAP.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.